Help with Tail/Brake light problem - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Nov 23rd, 07, 04:49 AM Thread Starter
Senior Tech
 
Join Date: Jul 2005
Location: Western Australia
Posts: 172
Help with Tail/Brake light problem

Tonite, I took my 68 out for a quick spin to the liquor store and when I came out I noticed I had left the lights on, but one of my tailights was out. When I got home, I pulled the connector out of the housing and jiggled the globe a little and the tailight came back on. I then got my son to test the brake light, but when he applied the brake, the light went out. Same thing, jiggle the globe, on comes the light, apply the brake, light goes out. Any ideas? Is it a faulty connector? Globe looks OK.
AussieCamaroOwner is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Nov 23rd, 07, 08:38 AM
Senior Tech
Jon
 
Rodder's Avatar
 
Join Date: Jul 2006
Location: Roswell, GA
Posts: 1,431
Send a message via AIM to Rodder Send a message via Yahoo to Rodder
Re: Help with Tail/Brake light problem

Common problem... the contacts corrode and make an intermittant connection to the bulb and/or the housing (ground). Aftermarket sockets are even worse than old original ones. I've seen other people have good luck with new factory-style sockets from AAW. For mine, I put LED conversions boards in.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- LS1, T56, Hooker longtubes, Autokraft pan & mounts, GM LS7 clutch, Borla ProXS, Moser/Strange/Wilwood 9", Covans dash, UltraLite IIs, Procar Elites, Vintage Air GEN-IV, AGR 12:1 steering, Addco swaybars, Hydratech hydroboost
Rodder is offline  
post #3 of 6 (permalink) Old Nov 23rd, 07, 05:52 PM Thread Starter
Senior Tech
 
Join Date: Jul 2005
Location: Western Australia
Posts: 172
Re: Help with Tail/Brake light problem

Update. Just to be sure, I purchased 2 new globes. Now the brake lights work, but the tail lights don't! When the lights are switched on, the brake lights don't work either, they only work when the lights are switched off. Help!
AussieCamaroOwner is offline  
 
post #4 of 6 (permalink) Old Nov 24th, 07, 11:13 AM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: Help with Tail/Brake light problem

Inspect the sockets for signs of heat fatigue and improperly aligned connections. Brighten up any burned areas, reshape any misalignment and then lightly dope the electrical connections with dielectric grease.

The problem with bad connections is that they snow-ball very quickly once they start. Dielelectric grease is one way of keeping things under control. It prevents oxygen from getting into the connection and leading to corrosion.

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
post #5 of 6 (permalink) Old Nov 24th, 07, 02:01 PM
Gold Lifetime Member
Fred
 
Join Date: Nov 2006
Location: Seabeck WA
Posts: 8,375
Re: Help with Tail/Brake light problem

Memories! I hated those early GM bulb sockets. They fixed them in 69. All of my bulbs work great. All but two are original too.
Not sure of your 68 but the drill used to be; Clean, clean, clean.

One owner 69 Camaro,(yep, bought it new
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
RS SS Hugger Orange, L88, 4:10's tru-tack posi, ducted hood, Endura, spoilers.
TH400 (CX) with Coan 8" converter, GV-OD, 8 track still on console and best et 10.495,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
128.79mph 1.428 60'
All with 1960's stuff. (except tires and converter)
+ MT Super Scavenger headers & 3" full exhaust with X pipe. 3700 lbs. with me in it.
1000cfm AED and HD Harold-Lunati SR, 725 lift with shaft rockers too.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Fred Ficarra is offline  
post #6 of 6 (permalink) Old Nov 26th, 07, 08:39 AM Thread Starter
Senior Tech
 
Join Date: Jul 2005
Location: Western Australia
Posts: 172
Re: Help with Tail/Brake light problem

Thanks guys. I got them working after some trial and error. I really want to upgrade to some LED tailights. Who makes the LED conversion kits that are not sequential?
AussieCamaroOwner is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome