67 heater resistor woes... - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Dec 4th, 07, 12:17 PM Thread Starter
Senior Tech
Scott
 
Join Date: Jul 2007
Location: Louisiana
Posts: 327
67 heater resistor woes...

i am having a problem with my blower motor resistor (no a/c just heater)my original blower motor resistor for my 67 camaro is dead so i bought a replacement from year one..Year One Item number: 7877N it seems like it would be the same exact thing just a little better design than the orginal...however it dosent cover the hole from the orginal only allowing for one of the two screws that hold in on the heater box. also, when i plug it in and run the fan it blows the fuse...i tried my orginal and it worked perfectly...sadly when i tried to remove it from the plug i broke off the springs from one of the prongs...so, its dead. they only sell one resistor at year one and it does say that its for a a/c car but the springs are idintcal to the orginal..any clues?
Scott MH is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome