69 AM Radio question - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jan 14th, 08, 03:57 PM Thread Starter
Tech Team
 
Join Date: Jul 2006
Posts: 56
69 AM Radio question

Does anyone know why there is a terminal on the back of these AM radios that says "lamp" but no power lead for it on the harness? In fact the terminal isn't even attatched to anything in the radio? It just comes out with your fingers? Strangely, I could have sworn I saw the lamp come on when I hooked it up last night and tonight...no lamp. I hooked up the re-built speaker tonight also to find no sound either. It shouldn't matter left to right speaker wire being crossed, should it? And there is only one ground wire for the radio correct? The one on the harness?
Mochatea396 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jan 14th, 08, 04:45 PM
Gold Lifetime Member
Kevin
 
SixtyAte's Avatar
 
Join Date: May 2005
Location: S. Eastern Massachusetts
Posts: 5,536
Re: 69 AM Radio question

Try grounding the radio in the dash or ground the case also and see if it works.

Kev
SixtyAte is offline  
post #3 of 5 (permalink) Old Jan 14th, 08, 05:22 PM Thread Starter
Tech Team
 
Join Date: Jul 2006
Posts: 56
Re: 69 AM Radio question

Ok, total brain fart on my part, after checking the terminal and seeing there is no power, scratching my head wondering why no power, of course it won't work with no power, but why no power? Hmmm, maybe if I turn the ignition key on it might work? Ahhhh!!!!!, Sometimes I wonder how this car had gotten as far as it has. Thanks again. I do however have another problem...no brake lights.
Mochatea396 is offline  
 
post #4 of 5 (permalink) Old Jan 15th, 08, 04:28 AM
Senior Tech
 
Join Date: Jul 2001
Location: Columbus, GA
Posts: 867
Re: 69 AM Radio question

I believe the radio light is powered by the main power source.
As for the brake lights, the switch at the pedal is simple to remove and work on. Just remove it and clean it to see if that helps. Of course you should check the fuses and bulbs first.

Dave, member number 7704
2000 Dodge Viper GTS
drdave69 is offline  
post #5 of 5 (permalink) Old Jan 15th, 08, 11:33 AM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,316
Re: 69 AM Radio question

Quote:
maybe if I turn the ignition key on it might work? Ahhhh!!!!!,
I hook mine into the cigarette lighter Orange wire)...thats live all the time
That way u can have sounds with no ignition key.

No brake lights use a probe (bulb in a probe and a ground wire ) follow the power
Check the earth terminal in the bulb housing...these get coroded and that ground wire at the body.

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome