67 camaro battery problems - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Jan 26th, 08, 10:54 PM Thread Starter
 
Join Date: Jan 2008
Posts: 4
67 camaro battery problems

Hi all, found this forum trying to find answers to my problem and you guys seem to know what your doing so hopefully I can get this figured out.

So here's the deal. My camaro has either a drain or an overcharge going on and I'm not really sure which one as I'm faily new to this whole thing. I have replaced the battery twice, the alternator, and the regulator, and new battery cables, all to no avail. When I brought the first battery back they told me it was fried. My machanic started checking all the wires and hooked in another new alternator and it supposibly fried that but I can't confirm that for myself. When I jump start the car it will work fine for about the entire day. I can turn it off and on for that day. After sitting overnight though the battery will be completly dead in the morning and won't have enough energy to even attempt to start. It does have rs hideaway lights but I disconnected them all because I thought that might be the drain unless I missed a spot. Anything on this would be greatly appreciated as I'm getting desprete.
HebrewHammer is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Jan 27th, 08, 05:04 AM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: 67 camaro battery problems

Welcome to the site.

Have you tried searching the forums for keywords like "battery drain"? Give it a try and see if that doesn't get you going.

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
post #3 of 6 (permalink) Old Jan 27th, 08, 05:23 AM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: 67 camaro battery problems

Welcome to the site for sure!

Are you gonna be fixing this, or continuing to take it to "your mechanic"?
If you want to fix it yourself, do you own a voltmeter and have at least a vague idea how to use it?
This would be a good place to start: https://www.camaros.net/forums/showthread.php?t=71062





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
 
post #4 of 6 (permalink) Old Jan 27th, 08, 02:50 PM Thread Starter
 
Join Date: Jan 2008
Posts: 4
Re: 67 camaro battery problems

Thanks for the suggestions I'll defently start searching around. It will remain at my machinc but I want to make sure I can fix it as fast as possible as I don't wanna be paying this guy a fortion. I'll let you know how this goes.
HebrewHammer is offline  
post #5 of 6 (permalink) Old Jan 27th, 08, 04:07 PM Thread Starter
 
Join Date: Jan 2008
Posts: 4
Re: 67 camaro battery problems

Just 1 more quick question before I start on this. Does it sound like my car could be overcharging or is it defently a drain? If it is overcharging would I be looking for anything differently?
HebrewHammer is offline  
post #6 of 6 (permalink) Old Jan 27th, 08, 05:00 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: 67 camaro battery problems

Without putting a voltmeter on it, nobody knows.
If you have a professional in your employ, I'd assume he knows this and has done it, but your post seems to indicate people have been throwing a lot of parts at it over and over. That's simply not a good diagnostic practice.

What's the voltage at the battery with the engine running?

If you disconnect the neg battery cable, and connect a test light, one lead to the battery neg and the other to the disconnected cable, does the light glow?





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome