oil pressure warning light won't work - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Feb 7th, 08, 06:30 PM Thread Starter
 
Join Date: Jan 2008
Posts: 14
oil pressure warning light won't work

Oil warning indicator lite in the dash won't work. Has a new sending unit.The altenator lite comes on when the ignition is turned on, the temp lite comes on when the key is in the start position then goes out when the engine starts, is this correct ? ( bulb is good ) I didn't know if the oil & temp lights should come on in the on position or only in the start position.
One wire from sender, two wires in plug to guage on circut board. HELP!

herb68 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Feb 7th, 08, 07:08 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: oil pressure warning light won't work

Temp light behavior is correct.

Oil light should be on with key on, engine not running, like the gen light. Are you sure the bulb is good? Try disconnecting the sender, put a jumper wire in it's harness connector, and ground the other end, bulb should light. If it does, sender is bad. If it doesn't, test voltage between the connector and ground, should be 12 volt with key on. If it's not, there s an open in the wiring or a burned out bulb.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #3 of 5 (permalink) Old Feb 7th, 08, 07:28 PM
Senior Tech
Mark
 
Join Date: Sep 2000
Location: Shrewsbury, MA, USA
Posts: 6,509
Re: oil pressure warning light won't work

You're not using plumbers tape on the oil pressure switch are you? Switch grounds to the block when pressure is less than the setpoint, so you can't use any teflon tape or plumbers dope on the threads.

With the engine off check continuity from the connector on the switch to the block, should be 0 ohms. Should be infinite (open circuit) with the engine running (assuming you have oil pressue)

Mark Canning
1969 Indy Pace Car
350/300HP RPO Z11

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mark C is offline  
 
post #4 of 5 (permalink) Old Feb 7th, 08, 09:02 PM
Senior Tech
 
Join Date: Feb 2007
Location: right of center
Posts: 993
Re: oil pressure warning light won't work

i've found that the printed circuit board can be dirty and even with a new bulb, might take some twisting to make a good contact. i replaced all of my instrument cluster with new lights and after installing it half of them wouldn't work. i had to pull it out and use a multimeter to 'finesse' the sockets in the right place for continuity.
guccieng is offline  
post #5 of 5 (permalink) Old Sep 12th, 10, 06:54 PM
Tech Team
Mike
 
Join Date: Sep 2010
Location: Philadelphia
Posts: 40
Re: oil pressure warning light won't work

Herb68,

Did you find the source of your problem? I'm experiencing the exact same condition.
MCat67SS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome