67 Windshield Washer overhaul kit - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Feb 21st, 08, 02:58 PM Thread Starter
 
Join Date: Sep 2005
Posts: 79
67 Windshield Washer overhaul kit

I have been trying to buy this kit, from three different places and ALL of them show a round rubber seal from the distribution plate to the pump assembly. My unit has a rubber seal that prevents the water from getting into the pump assembly (a complete seal in rubber, not just a outer rubber seal) is this a later unit or what is my problem?
Ken
Nomadkenn is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Feb 21st, 08, 07:49 PM Thread Starter
 
Join Date: Sep 2005
Posts: 79
Question Re: 67 Windshield Washer overhaul kit

Some one must have run into this problem before, please HELP! I will try to attach one picture to show what I am talking about. The top part shows the replacement and the bottom part is my old part that needs replacement.
Attached Thumbnails
Click image for larger version

Name:	IMG_0461_edited-1.jpg
Views:	73
Size:	51.7 KB
ID:	5710  
Nomadkenn is offline  
post #3 of 4 (permalink) Old Feb 22nd, 08, 05:00 AM
Gold Lifetime Member
Scott
 
1st 67 SS/RS's Avatar
 
Join Date: Oct 2006
Location: Royal Palm Beach, Florida
Posts: 529
Re: 67 Windshield Washer overhaul kit

The part is not listed for a Camaro anywhere. But the Corvette has the same part - 63 -67 windshield washer bellow kit. Here is a site that has a picture http://www.grilleteeth.com/shop/shopcat.asp?cat=washer. I found one for my 67 vert at a local Corvette restoration shop for $12. It fits good. Now I just need to get the electical switch for the pump working.

67 Vert RS/SS 350 4 SP
1st 67 SS/RS is offline  
 
post #4 of 4 (permalink) Old Feb 22nd, 08, 11:46 AM Thread Starter
 
Join Date: Sep 2005
Posts: 79
Re: 67 Windshield Washer overhaul kit

Wow, 1st 67 SS/RS, you are the man! The one and only, so far to know what I have been going through for the last few weeks!
The grilleteeth site talks about a spring, since mine did not have one where would it go?
The electrical switch problem just may be getting a good ground to the switch since the switch must provide ground to the electrical circuit.
Good Luck!
Ken
Nomadkenn is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome