67 rs wiring nightmare! - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old Feb 26th, 08, 10:27 PM Thread Starter
 
Join Date: Feb 2008
Posts: 11
67 rs wiring nightmare!

Hi everybody! Found this site last night and signed in then made the mistake of posting my problem on the "welcome wagon". My name is Roger and I always liked the first gen. camaro so my wife got me a 67 rs for my birthday. It is still hard to believe. Sounds like there is alot of knowledge on this site. Car runs great but after about a week the gen light came on and the dome light would stay on. Put in new door switches and had the battery and the alternator tested and they are fine. Checked the regulator and it was all wet so I got a new regulator then it happend. The car runs fine but now the headlight doors won't open and the drivers side headlight is really dim. There are ground wires from the motor to the frame and the fire wall and core support. Went for a ride tonight and stopped at my buddy's house to show him the car and when I shut the door the dome light stayed on. Drove the car home and when I was pulling in the garage hear a click and the dome light went off. Thinking about changing the light switch. Any suggestions would be greatly appreciated. Thanks
SPARKY952 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old Feb 26th, 08, 11:05 PM
Senior Tech
Brandon
 
Join Date: Feb 2007
Location: Petaluma Ca
Posts: 110
Re: 67 rs wiring nightmare!

It sounds to me that your problems are mostly a bad ground.
I would try to take apart and clean as many of the ground connections (where the wires meet the body or frame) as you can find. That is probably where most of your problems are coming from.
as for the dome light gremlins??? try to replace the switch?
why was the regulator all wet?
Hope this helps Rodger
BTW post some pictures of your Bday present we would like to see it too

Pix of my cars...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
brandonc707 is offline  
post #3 of 10 (permalink) Old Feb 27th, 08, 04:06 AM
Gold Lifetime Member
Scott
 
1st 67 SS/RS's Avatar
 
Join Date: Oct 2006
Location: Royal Palm Beach, Florida
Posts: 529
Re: 67 rs wiring nightmare!

Check out this site for wiring diagrams http://www.gvtc.com/~rlaa/ I have used the 67 RS diagram to troubleshoot me headlight problem. I found the previour owner had switched a couple of the wires on the relays and the diode under the dash was bad. Check the grounds first.

67 Vert RS/SS 350 4 SP
1st 67 SS/RS is offline  
 
post #4 of 10 (permalink) Old Feb 27th, 08, 04:30 AM
Senior Tech
Dave
 
Join Date: Jun 2005
Location: Kenosha,Wisconsin
Posts: 209
Re: 67 rs wiring nightmare!

I agree with grounding problem. I had the same situation with the headlight going dim. I found a grounding wire broke off the tab. the ground wire I found broken was in front of the washer bottle on the passenger side. I stripped off some of the coating and wrapped the wire around the tab and the screw. Worked fine until I could change out the headlight wire harness. The problem with the headlight doors could be a number of things besides a bad ground. could be the switch for the headlights or a bad door motor. Hope it is just a ground sure sounds like it. Good luck!!!!!!!!!!!!!!!!!!!

Dave

67 SS350 (NON MATCHING)

350 V8
2SPD PWR GLIDE WITH CONSOLE AND GAUGES
PLUM WITH WHITE VINYL ROOF
TILT WHEEL
REAR ANTENNA
PS.PB
EXTERIOR CHROME PACKAGE
STD BLACK INTERIOR
DELUXE SEAT BELTS
Dave Burlingham is offline  
post #5 of 10 (permalink) Old Feb 27th, 08, 06:04 AM Thread Starter
 
Join Date: Feb 2008
Posts: 11
Re: 67 rs wiring nightmare!

thanks I'll clean the grounds and see what happens!
SPARKY952 is offline  
post #6 of 10 (permalink) Old Feb 27th, 08, 06:17 AM Thread Starter
 
Join Date: Feb 2008
Posts: 11
Re: 67 rs wiring nightmare!

Quote:
Originally Posted by brandonc707 View Post
It sounds to me that your problems are mostly a bad ground.
I would try to take apart and clean as many of the ground connections (where the wires meet the body or frame) as you can find. That is probably where most of your problems are coming from.
as for the dome light gremlins??? try to replace the switch?
why was the regulator all wet?
Hope this helps Rodger
BTW post some pictures of your Bday present we would like to see it too
The engine compartment is clean so they seller probably steam cleaned it before I got it. I will get some pictures out there.
SPARKY952 is offline  
post #7 of 10 (permalink) Old Feb 27th, 08, 06:20 AM Thread Starter
 
Join Date: Feb 2008
Posts: 11
Re: 67 rs wiring nightmare!

Quote:
Originally Posted by 1st 67 SS/RS View Post
Check out this site for wiring diagrams http://www.gvtc.com/~rlaa/ I have used the 67 RS diagram to troubleshoot me headlight problem. I found the previour owner had switched a couple of the wires on the relays and the diode under the dash was bad. Check the grounds first.
Thank you for the site I will check it out !
SPARKY952 is offline  
post #8 of 10 (permalink) Old Feb 27th, 08, 06:23 AM Thread Starter
 
Join Date: Feb 2008
Posts: 11
Re: 67 rs wiring nightmare!

Quote:
Originally Posted by Dave Burlingham View Post
I agree with grounding problem. I had the same situation with the headlight going dim. I found a grounding wire broke off the tab. the ground wire I found broken was in front of the washer bottle on the passenger side. I stripped off some of the coating and wrapped the wire around the tab and the screw. Worked fine until I could change out the headlight wire harness. The problem with the headlight doors could be a number of things besides a bad ground. could be the switch for the headlights or a bad door motor. Hope it is just a ground sure sounds like it. Good luck!!!!!!!!!!!!!!!!!!!

Dave
I will check all the grounds first and if that does'nt work then I willcheck out a wiring diagram and start troubleshooting the doors.
SPARKY952 is offline  
post #9 of 10 (permalink) Old Feb 29th, 08, 11:01 PM
Moderator
David Pozzi
 
davidpozzi's Avatar
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 10,080
Re: 67 rs wiring nightmare!

The headlight doors use a relay assy under the RH fender just behind the left headlight/radiator support. It's tucked underneath and a bolt through the fender holds it.
The assy has a circuit breaker on it that can wear out and make poor contact inside.
Clean any connections you may find.
David

Check my web page for First Gen Camaro suspension info:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

67 RS 327 original owner. 1965 Lola T-70
davidpozzi is offline  
post #10 of 10 (permalink) Old Mar 3rd, 08, 06:15 PM Thread Starter
 
Join Date: Feb 2008
Posts: 11
Re: 67 rs wiring nightmare!

Quote:
Originally Posted by davidpozzi View Post
The headlight doors use a relay assy under the RH fender just behind the left headlight/radiator support. It's tucked underneath and a bolt through the fender holds it.
The assy has a circuit breaker on it that can wear out and make poor contact inside.
Clean any connections you may find.
David
Thanks I will take a look at those relays.
SPARKY952 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome