Ken' 86 IROC - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Mar 6th, 08, 03:54 PM Thread Starter
 
Join Date: Dec 2006
Posts: 3
Ken' 86 IROC

My 86 Iroc's Tach,oil pressure and their light comes on for 10 to 20 mins.. Then goes off for 10 or so mins.. It depends on if the A/C or heat is on. They stay off longer if the heat is on. I have switched the clusters and still have the same problem. A guy told me he had this problem. After changing his heater coil the problem went away. I think it is heat related problem but where. I have pushed on and pulled on everything I can with no result. Has anyone had this problem? If so what was it? Also does anyone know where I can get a new circuit board for my gages. Any help will be greatly appreciated.
Ken's 86 IROC is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome