Christine Revisited? - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Apr 3rd, 08, 07:18 AM Thread Starter
Gold Lifetime Member
JB
 
Join Date: Aug 2006
Location: El Dorado Hills, CA
Posts: 313
Christine Revisited?

Last night I connected the horns on my 67 RS. After bolting them on and connecting the leads, I couldn't get them to work (and I knew the horns work). I went in for dinner and about 15 minutes later with nobody near the car, the horns started blasting away!!! I had to go out and disconnect the leads (apparently the horn button is stuck) to get it to stop. Any idea why they wouldn't make any noise when I connected them but then started by themselves later?

1967 Marina Blue RS Coupe:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2011 Red Jewel Tintcoat RS Convertible:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1967 Madeira Maroon Coupe (barn find):
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
edhjohnb is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome