Are these 10SI chrome alternators plug and play? - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old Jun 1st, 08, 06:18 PM Thread Starter
Senior Tech
Timothy
 
Join Date: Sep 2007
Location: San Antonio TX
Posts: 1,804
Are these 10SI chrome alternators plug and play?

Are these plug and play with our first gen cars?

100% NEW CHROME CHEVY 3 WIRE ALTERNATOR 105 AMP

They say they are the 10SI unit and they use external voltage regulation. I realize I may need a larger red wire. But I noticed the alternator in use gets hot to the touch. Are there any other changes I should make? It is charging. I just dont want trouble down the road.

I also read in another thread that the 10SI was internally regulated.

My 69 RS/SS 396 Project -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"I may be dumb but I aint stupid"

Last edited by Microgiant; Jun 1st, 08 at 06:55 PM.
Microgiant is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old Jun 1st, 08, 06:30 PM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,487
Garage
Re: Are these 10SI chrome alternators plug and play?

I think it's a one wire alt... It's a fairly easy swap to get rid of the voltage reg if it is a one wire...

...Dennis

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Don't take life so serious, you won't get out alive..."
DjD is offline  
post #3 of 7 (permalink) Old Jun 1st, 08, 06:51 PM Thread Starter
Senior Tech
Timothy
 
Join Date: Sep 2007
Location: San Antonio TX
Posts: 1,804
Re: Are these 10SI chrome alternators plug and play?

Sorry I should have mentioned its a 3-wire. It has the plug orientation like this _ _ instead of this ||

I changed out the plug
and got it wired right. Its charging. I read if its internally regulated and I hook it up to a regulator it will charge constantly and run hot. Is that what I did?

TIA
Microgiant is offline  
 
post #4 of 7 (permalink) Old Jun 1st, 08, 07:54 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Are these 10SI chrome alternators plug and play?

That is an internal regulator alternator. You need to remove the regulator and put in a bypass plug. The bypass plug connects the top and bottom wires of the reg plug, and separately connects the middle two wires.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #5 of 7 (permalink) Old Jun 9th, 08, 04:55 PM Thread Starter
Senior Tech
Timothy
 
Join Date: Sep 2007
Location: San Antonio TX
Posts: 1,804
Re: Are these 10SI chrome alternators plug and play?

Thanks Jim, I changed over the wires to the same configuration as your sticky. I also installed the tach filter you designed and its working great. Thanks for all your help!


However my Ammeter no longer works. Is there a way to get it working with the internally regulated alternator?
Microgiant is offline  
post #6 of 7 (permalink) Old Jun 9th, 08, 06:48 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Are these 10SI chrome alternators plug and play?

The ammeter should still work (this is a factory console gauge ammeter, right?)
Best guess is something came loose when you were messing around by the regulator. The ammeter will be the smallest wire attached (or used to be attached) to one of the horn relay screws. Be careful, it's hot!





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #7 of 7 (permalink) Old Aug 4th, 08, 08:12 AM
Senior Tech
Mike
 
Join Date: Dec 2002
Location: Motor City
Posts: 1,097
Re: Are these 10SI chrome alternators plug and play?

Quote:
Originally Posted by Microgiant View Post
However my Ammeter no longer works. Is there a way to get it working with the internally regulated alternator?
Tim did you ever get the ammeter to work again? I need a new alt. and was thinking of converting to a one wire alt, but want to make sure my original factory ammeter still is fully funtional.

Thanks.
Mike


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mike68RS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome