68 camaro headlights stoped working - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Oct 24th, 08, 01:59 PM Thread Starter
Senior Tech
 
knightmoose's Avatar
 
Join Date: Mar 2004
Location: Los Angeles California
Posts: 620
Unhappy 68 camaro headlights stoped working

68 camaro everything stock original, headlights stopped working for the first time this morning whyen i went to turn them on nothing, tail lights front parking lamps, turn signal everything else works fine,

Looked under hood everything intact headlight lamps not burned out, i have a square metal box where the lights are at with a cycnder small condesor have no idea if they have anything to do with headlamps, quaetion is if everything else works would you say its the headlamp switch itself as today was out first day under 40 over nite?

it about helping others
knightmoose is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Oct 24th, 08, 02:13 PM
Retired
Jim
 
click's Avatar
 
Join Date: Jun 2001
Location: Central Minnesota
Posts: 15,986
Re: 68 camaro headlights stoped working

bet its the dimmer switch at your left foot floorboard area. Either wire plug pulled loose or the switch lost its ground.

Click..is Jim..former owner of a 69RS-LM1 350/255 - 700r
"There will come a time when you believe everything is finished,
That will be the beginning." Louis L'Amour
click is offline  
post #3 of 4 (permalink) Old Oct 26th, 08, 12:03 PM Thread Starter
Senior Tech
 
knightmoose's Avatar
 
Join Date: Mar 2004
Location: Los Angeles California
Posts: 620
Re: 68 camaro headlights stoped working

thanks it was the headlight switch itself, replaced it 13.99 at autozone, pulled out instrunement guage cluster pretty easy thanks

it about helping others
knightmoose is offline  
 
post #4 of 4 (permalink) Old Oct 26th, 08, 06:48 PM
Senior Tech
Mike
 
Join Date: Apr 2001
Location: Gibsons,B.C. Canada
Posts: 424
Re: 68 camaro headlights stoped working

my bet would have been the dimmer switch too. had it happen once!

69 Camaro RS/SS 350.<br />GM 2.02 angle plug heads.<br />223 dur/480 lift hyd cam.<br />69 z/28 alum high rise.<br />69 z/28 780 vac sec holly carb.<br />4 bolt mains,steel crank,forged flat top pistons.<br />Turbo 350 2800 stall with shift kit.<br />3:73 12 bolt posi.<br />functional ZL2 cowl induction hood<br />gear vender O.D.<br />13.2 in the 1/4 with slicks and open headers
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
z/27 camaro is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome