Hazard Light Issue ... All Parking/Turn Light Steady On, not Flashing! - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Jan 5th, 09, 07:15 PM Thread Starter
Senior Tech
 
Join Date: Jan 2005
Location: Raleigh, NC
Posts: 382
Hazard Light Issue ... All Parking/Turn Light Steady On, not Flashing!

Hi all,

I'm pretty much finished with my project ... I hope!!!

Just trying to fix a couple of gremlins ...

Here's the deal ... The Hazard lights (American Autowire Kit) worked fine a couple of months back in the build ...

Currently All lights (interior and exterior) work correctly ... Turn Signals Fine, Gauges seem fine, Horn fine, highbeams, etc ...

Except that now the Hazard Lights will not flash when the steering column switch is pressed in, they all come on ... but just stay steady on ... no flashing ...

Checked fuses, all ground connections, removed the hazard blinker and reinstalled ... etc ...

Nothing seems to fix this issue ...

Could this new hazard blinker gone bad and I just need to replace it ???

I originally felt like it's a ground issue ... but everything works and checks out maybe I've missed something ...

Anything else to check or ideas ???

Thanks!

'95 383 CAMARO Z28 - C.A.M. BUILT/TUNED
405 RWHP/428 RWTQ (SAE DynoJet)
'99 CORVETTE
'68 CAMARO - 383+D1SC, Orion Silver
Tim_in_NC is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jan 5th, 09, 07:23 PM Thread Starter
Senior Tech
 
Join Date: Jan 2005
Location: Raleigh, NC
Posts: 382
Re: Hazard Light Issue ... All Parking/Turn Light Steady On, not Flash

As soon as I wrote this ... I thought, hey dummy ... Why don't you try the Turn Signal Blinking in the Hazard Blinker location and see what happens ...

Well ... The Blinkers now work and the Turn Signals don't ...

Looks like I'm off to pick up a new blinker ...

Wonder why this Basically New Blinker/Flasher went out to lunch???

I'm so nuts some times !!! !!!

'95 383 CAMARO Z28 - C.A.M. BUILT/TUNED
405 RWHP/428 RWTQ (SAE DynoJet)
'99 CORVETTE
'68 CAMARO - 383+D1SC, Orion Silver
Tim_in_NC is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome