window washer breakthrough???? - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Feb 9th, 09, 11:46 AM Thread Starter
Tech Team
gregg
 
Join Date: Nov 2008
Location: shippensburg pa
Posts: 63
window washer breakthrough????

I checked the forums, alot of different discussions about the window washer pump remaining on all the time. I was having some trouble finding "WHY" my washers remained on. Here is what helped me,,
I removed the washer motor, behind the washer motor I noticed a star shaped mechanism that rotates when the wipers are on. This would rotate the wheel inside the washer motor housing. So .. why is my washer always running. The car had set for a long time and it was all I could do to pull the plunger out of the square box that it goes in, by pulling up on the little rod behind the wiper motor. I sprayed the entire motor, except the coil with WD 40, the plunger started popping in/out much easier. kept cleaning and working the plunger, put it back on the wiper motor and it now works properly!!! I even get some window cleaner to the windows. Maybe not a full shot, but some!! I tried priming the system but I m not sure I know how!!
gemstick is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Feb 9th, 09, 05:25 PM
Gold Lifetime Member
Fred
 
Join Date: Nov 2006
Location: Seabeck WA
Posts: 8,375
Re: window washer breakthrough????

Welcome gregg. And thanks for another WD40 success story!

One owner 69 Camaro,(yep, bought it new
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
RS SS Hugger Orange, L88, 4:10's tru-tack posi, ducted hood, Endura, spoilers.
TH400 (CX) with Coan 8" converter, GV-OD, 8 track still on console and best et 10.495,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
128.79mph 1.428 60'
All with 1960's stuff. (except tires and converter)
+ MT Super Scavenger headers & 3" full exhaust with X pipe. 3700 lbs. with me in it.
1000cfm AED and HD Harold-Lunati SR, 725 lift with shaft rockers too.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Fred Ficarra is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome