67 RS Relayboard - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old Mar 11th, 09, 05:49 AM Thread Starter
Senior Tech
Lars
 
67 Sinner's Avatar
 
Join Date: Nov 2005
Location: Norway
Posts: 136
67 RS Relayboard

Hi!

Does anybody got a complete chart over wich wire goes where from the three relays on the relayboard?

I'm not sure if my problem lies there, but I've just installed a RS grille on my standard coupe, and everything works like a charm, except drivers side park/turn light..
bulb is ok, and I've tried ground everywhere. Seems like it's not getting any "juice".. So I was wondering if it could be something with the relays, but as I've mentioned, I don't know if they are connected trough the relays..

cheers

Lars

Newbie from the North
'67 Camaro 350 / 350 (part RS-clone)
67 Sinner is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old Mar 11th, 09, 06:01 AM
Senior Tech
 
Join Date: May 2004
Location: Southeast PA
Posts: 8,303
Re: 67 RS Relayboard

If you look about halfway down the page of this link, there's a 1967-69 rs console gauge & headlight wiring diagrams downolad. http://www.gvtc.com/~rlaa/

I think page 10 of the PDF has what you're looking for.

Eric
69 'vert project big block/TKO 600 RR
68 'vert driver RS clone -- gone!
Eric Kammerer is offline  
post #3 of 9 (permalink) Old Mar 11th, 09, 06:09 AM Thread Starter
Senior Tech
Lars
 
67 Sinner's Avatar
 
Join Date: Nov 2005
Location: Norway
Posts: 136
Re: 67 RS Relayboard

Thanks!
But I was thinking the relays have so and so many connectors on them, and this diagram shows just a few of them. Putting it otherwise, you could say a picture of the entire front harness without the wrap on it.. Did that make sense?

Newbie from the North
'67 Camaro 350 / 350 (part RS-clone)
67 Sinner is offline  
 
post #4 of 9 (permalink) Old Mar 11th, 09, 06:19 AM
Gold Lifetime Member
Tom
 
Join Date: Mar 2008
Location: the 02176
Posts: 5,987
Re: 67 RS Relayboard

Lars, The parking lights are in no way connected to the relays.
This link shows each relay connection. http://www.retro-electro.net/FAQ.html
But if you doors are working right, you've got no relay trouble!

'67 rs - ordered new by my Grandfather
327 L30, K-K, Deluxe int, tach & gauges, 12 bolt posi, 4 speed.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Melrose RS is offline  
post #5 of 9 (permalink) Old Mar 11th, 09, 06:23 AM Thread Starter
Senior Tech
Lars
 
67 Sinner's Avatar
 
Join Date: Nov 2005
Location: Norway
Posts: 136
Re: 67 RS Relayboard

Ok,thanks. Guess I'll have to rip out the lightswitch then..Brand new harness, and shouldn't be a breach in that anywhere...the pass.side parklight wires are just an extension of the drivers side, right?Then they should work when properly grounded....?

and regarding the different connectors on the relays, I guess I can't express my self right..(those pesky foreigners)
I mean where does ex. the black wire from relay one go?
is that black wire divided somewhere, if so where does it go..
I don't know how to say this, but I needed it for troubleshooting my headlight doors when first installed..
And why isn't the headlightmotors included in the diagram..they seem to be important for the functioning of the headlightdoors..

Newbie from the North
'67 Camaro 350 / 350 (part RS-clone)

Last edited by 67 Sinner; Mar 11th, 09 at 06:29 AM. Reason: More on my mind..
67 Sinner is offline  
post #6 of 9 (permalink) Old Mar 11th, 09, 06:36 AM
Gold Lifetime Member
Tom
 
Join Date: Mar 2008
Location: the 02176
Posts: 5,987
Re: 67 RS Relayboard

Check your connectors closest to each park light first. But,From the Bulkhead connector, Purple goes to each, Light Blue to the driver's side, Dark Blue to the passenger's side. I'd trace it back with a 12V test light.

Here's a photo of my switch connections if you want to check that.

'67 rs - ordered new by my Grandfather
327 L30, K-K, Deluxe int, tach & gauges, 12 bolt posi, 4 speed.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Melrose RS is offline  
post #7 of 9 (permalink) Old Mar 11th, 09, 06:44 AM
Gold Lifetime Member
Tom
 
Join Date: Mar 2008
Location: the 02176
Posts: 5,987
Re: 67 RS Relayboard

The motors are the round circles on the right side of the diagram.
I think the black wire is grounded at the radiator support? No matter, to test if it is grounded at relay 1, hook your 12V test light to the (+) side of your battery and touch the test light to the black wire. If the test light lights, you've got GND there.

'67 rs - ordered new by my Grandfather
327 L30, K-K, Deluxe int, tach & gauges, 12 bolt posi, 4 speed.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Melrose RS is offline  
post #8 of 9 (permalink) Old Mar 11th, 09, 07:08 AM Thread Starter
Senior Tech
Lars
 
67 Sinner's Avatar
 
Join Date: Nov 2005
Location: Norway
Posts: 136
Re: 67 RS Relayboard

Ok.this pic I just made out of the blue, but it kind of shows what I mean..
but I'll leave it here. I've got something like this, laminated, but I mean it could be even more detailed..But that's me..

thanks for the pic, I'll check it out.

Lars
Attached Thumbnails
Click image for larger version

Name:	Sketch.jpg
Views:	91
Size:	16.9 KB
ID:	9550  

Newbie from the North
'67 Camaro 350 / 350 (part RS-clone)
67 Sinner is offline  
post #9 of 9 (permalink) Old Mar 11th, 09, 09:04 AM
Senior Tech
Mark
 
Join Date: Sep 2000
Location: Shrewsbury, MA, USA
Posts: 6,513
Re: 67 RS Relayboard

http://www.pozziracing.com/Media/67rswire2.jpg

Mark Canning
1969 Indy Pace Car
350/300HP RPO Z11

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mark C is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome