No Spark - MSD 6A - HEI - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old Mar 23rd, 09, 06:36 PM Thread Starter
Senior Tech
Mike
 
Join Date: Feb 2006
Location: LI NY
Posts: 408
No Spark - MSD 6A - HEI

Im trying to get my pig running after 5 years and not so sure I have things hooked up right. I have a 4 pin module in my HEI distributor. I removed that module and hooked the 2 wires inside the distributor to the MSD box's "magnetic Pickup" (purple & Green). Orange and black going to C+ & B+ on the HEI coil, and the middle pin on the HEI is grounded.

Please help this bodyman
test the system to know which component is bad.. Im bad with wires..

68 SS 357, AFR195, Hotchkis, TKO600, 3:73
Miikeremains is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old Mar 23rd, 09, 07:21 PM
Gold Lifetime Member
Skip
 
Skeeter55's Avatar
 
Join Date: Feb 2008
Location: CA
Posts: 6,628
Re: No Spark - MSD 6A - HEI

Is the ground from the MSD box grounded... I know you can check out the tech at www.msdignition.com go to tech forum.

I NEED TO HIT THE LOTTERY
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Skeeter55 is offline  
post #3 of 15 (permalink) Old Mar 23rd, 09, 07:43 PM Thread Starter
Senior Tech
Mike
 
Join Date: Feb 2006
Location: LI NY
Posts: 408
Re: No Spark - MSD 6A - HEI

Quote:
Originally Posted by Skeeter55 View Post
Is the ground from the MSD box grounded... I know you can check out the tech at www.msdignition.com go to tech forum.
I have it grounded to the firewall. I know the instructions say Battery -, but ground is ground right?

Also, do I need a ground strap from motor to body?

68 SS 357, AFR195, Hotchkis, TKO600, 3:73
Miikeremains is offline  
 
post #4 of 15 (permalink) Old Mar 23rd, 09, 07:49 PM
Gold Lifetime Member
Skip
 
Skeeter55's Avatar
 
Join Date: Feb 2008
Location: CA
Posts: 6,628
Re: No Spark - MSD 6A - HEI

Quote:
Originally Posted by Miikeremains View Post
I have it grounded to the firewall. I know the instructions say Battery -, but ground is ground right?

Also, do I need a ground strap from motor to body?
Yes the more grounds then better. But that may not be your problem have you check in side your cap at the black carbon button (that is where the coil wire fires off the spark to the carbon button). Have you tried to pull a plug to check for spark by turning the motor over. Also with the key in the on position check the coil leads with a test light to see if you are getting juice on both neg/pos sides.

I NEED TO HIT THE LOTTERY
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Skeeter55 is offline  
post #5 of 15 (permalink) Old Mar 23rd, 09, 07:52 PM Thread Starter
Senior Tech
Mike
 
Join Date: Feb 2006
Location: LI NY
Posts: 408
Re: No Spark - MSD 6A - HEI

its a new cap and button. Im using a timing light to check for spark. Its not lighting which is telling me nothing is coming through the wires.

68 SS 357, AFR195, Hotchkis, TKO600, 3:73
Miikeremains is offline  
post #6 of 15 (permalink) Old Mar 23rd, 09, 08:08 PM
Gold Lifetime Member
Skip
 
Skeeter55's Avatar
 
Join Date: Feb 2008
Location: CA
Posts: 6,628
Re: No Spark - MSD 6A - HEI

Read this link.

http://www.msdignition.com/forum/sho...ght=6al+wiring

I NEED TO HIT THE LOTTERY
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Skeeter55 is offline  
post #7 of 15 (permalink) Old Mar 23rd, 09, 08:46 PM
Gold Lifetime Member
Rick
 
Join Date: Jul 2004
Location: Yreka, CA
Posts: 346
Re: No Spark - MSD 6A - HEI

Just got done reading about this in the MSD manual (6AL2)

If triggering with the magnetic pickup:
1 make sure the ignition swith is in the "off" position
2 remove the coil wire from the distributor cap and set the (coil) terminal approximately 1/2 from ground
3 disconnect the MSD magnetic pickup wires from the distributor
4 turn the ignitior to the ON position. Do not crank the engine.
5 with a small jumper wire short the MSD green and violet magnetic pickup wires several times. Each time you break this short a spark should jump from the coil wire to ground. If spark is present the ignition is working properly. (Picture to side showing the violet/green plug from the box and a bent wire being placed in and out of each side of plug) If not go to step 6

Step 6
A inspect all wiring.
B substitute another coil and repeat the test. It these is now spark the coil is at fault.
C If there is still no spark, check to make sure there are 12 volts on the small Red wire from the MSD when the key is in the On position. If 12 bolts are present, find another switched 12 volt source and repeat the test.
D. if after following the test procedures and inspecting all of the wiring there is still no spark the MSD ignition is in need of Repair. See Warranty.

Rick

Last edited by dukemd66; Mar 23rd, 09 at 08:49 PM. Reason: spelling
dukemd66 is offline  
post #8 of 15 (permalink) Old Mar 24th, 09, 04:12 AM Thread Starter
Senior Tech
Mike
 
Join Date: Feb 2006
Location: LI NY
Posts: 408
Re: No Spark - MSD 6A - HEI

how do i disconnect the coil wire for testing if i dont have a coil wire? This is HEI.

68 SS 357, AFR195, Hotchkis, TKO600, 3:73
Miikeremains is offline  
post #9 of 15 (permalink) Old Mar 24th, 09, 06:11 AM
Rob
 
Join Date: Mar 2009
Location: Vancouver BC Canada
Posts: 27
Re: No Spark - MSD 6A - HEI

Sounds like you are following the (external coil ignition set-up) diagram
there are 2 ways to hook up that egnition timing module... (MSD 6A)
Be sure you are following the correct diagram
1.Coil
2.HEI
You must follow the correct diagram for the application...

Last edited by Mad Max; Mar 24th, 09 at 06:24 AM.
Mad Max is offline  
post #10 of 15 (permalink) Old Mar 24th, 09, 06:44 AM
Gold Lifetime Member
Mike
 
prostreet69camaro's Avatar
 
Join Date: Jul 2003
Location: Spring Texas
Posts: 5,580
Re: No Spark - MSD 6A - HEI

Just went to MSD website. It sucks for looking up a diagram. In your instructions it should show how to hook up the msd to a gm hei, either a 3 wire or 4 wire. Order a catalog and it has all the diagrams in it. Also you can call them and they can email it to you.

Mike
69 Camaro Prostreet - purple w/ghost flames , 502 w/ 871 blower


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
prostreet69camaro is offline  
post #11 of 15 (permalink) Old Mar 24th, 09, 01:28 PM Thread Starter
Senior Tech
Mike
 
Join Date: Feb 2006
Location: LI NY
Posts: 408
Re: No Spark - MSD 6A - HEI

Im going by this diagram here on page 28.... http://www.msdignition.com/uploadedF...pport/WDTN.PDF

This is for internal coil

68 SS 357, AFR195, Hotchkis, TKO600, 3:73
Miikeremains is offline  
post #12 of 15 (permalink) Old Mar 24th, 09, 06:13 PM Thread Starter
Senior Tech
Mike
 
Join Date: Feb 2006
Location: LI NY
Posts: 408
Re: No Spark - MSD 6A - HEI

Its alive!

MSD Box was cooked

68 SS 357, AFR195, Hotchkis, TKO600, 3:73
Miikeremains is offline  
post #13 of 15 (permalink) Old Mar 24th, 09, 06:36 PM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: No Spark - MSD 6A - HEI

Your intial post talked about a "4 pin module" and you described how you hooked it up to the pickup signal pins of the MSD box. I didn't think you used a "module" (presuming HEI module) on an MSD ignition setup. Perhaps I'm wrong - I didn't RTFM.

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
post #14 of 15 (permalink) Old Mar 25th, 09, 06:57 AM
Gold Lifetime Member
Rick
 
Join Date: Jul 2004
Location: Yreka, CA
Posts: 346
Re: No Spark - MSD 6A - HEI

Mike,
How did you figure it out?
Rick
dukemd66 is offline  
post #15 of 15 (permalink) Old Mar 25th, 09, 09:57 PM Thread Starter
Senior Tech
Mike
 
Join Date: Feb 2006
Location: LI NY
Posts: 408
Re: No Spark - MSD 6A - HEI

with your above post. Thanks!

68 SS 357, AFR195, Hotchkis, TKO600, 3:73
Miikeremains is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome