Headlights only work on High Beam - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old Apr 9th, 09, 08:38 AM Thread Starter
Senior Tech
James
 
Join Date: Sep 2004
Location: Fairview Heights, IL
Posts: 336
Send a message via Yahoo to james7773
Angry Headlights only work on High Beam

My 67 RS has an issue with her headlights. The doors work just dandy, but the only way to get the headlights to come on is turn on the highbeams. Ive replaced the dimmer foot switch, but get the same result. Anyone have another idea?
Thanks.

My 67 RS 327...its a work in progress.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
james7773 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old Apr 9th, 09, 10:03 AM
Gold Lifetime Member
Fred
 
77thor's Avatar
 
Join Date: Jun 2005
Location: Milwaukee, WI USA
Posts: 2,169
Re: Headlights only work on High Beam

I was going to say the floor dimmer switch.... but now I'm not sure.
Unless you got a bad(cheap) switch.

Is it possible that the low-beam is burned out in both headlights?

1969 Camaro SS, 350(NOM), M21, 12 Bolt Posi, 01B LOS Build
1977 Camaro, 350(LM1), M20, 10 Bolt Posi, Purchased New, (SOLD)
77thor is offline  
post #3 of 9 (permalink) Old Apr 9th, 09, 10:10 AM
Gold Lifetime Member
Matt
 
Join Date: Dec 2008
Location: Denver, CO
Posts: 3,123
Re: Headlights only work on High Beam

Mine did the same thing at one point in time on my 68RS. Make sure you check the ground wires that come off the headlights as well as make sure the wires that go into the plug that connects to the lamp itself are not lose. The issue resolved itself and the ground wires/plugs were the only thing I remember messing with...

Matt

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

zlek131 is offline  
 
post #4 of 9 (permalink) Old Apr 9th, 09, 10:22 AM
Gold Lifetime Member
Mike
 
prostreet69camaro's Avatar
 
Join Date: Jul 2003
Location: Spring Texas
Posts: 5,580
Re: Headlights only work on High Beam

If they work in the low beam then the ground is good. I would suspect the dimmer switch or a bad connection / crimp on the wiring. The dimmer switch has 3 wires. 1- power wire, 1 for low beam circuit, 1 for high beam circuit.

Mike
69 Camaro Prostreet - purple w/ghost flames , 502 w/ 871 blower


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
prostreet69camaro is offline  
post #5 of 9 (permalink) Old Apr 9th, 09, 02:44 PM Thread Starter
Senior Tech
James
 
Join Date: Sep 2004
Location: Fairview Heights, IL
Posts: 336
Send a message via Yahoo to james7773
Re: Headlights only work on High Beam

Ill re-check the dimmer switch, but when I got the car, no low beams....replace the dimmer switch, no low beams. I suppose its a remote possibility that both low beams are gone, but that seems remote at best.

My 67 RS 327...its a work in progress.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
james7773 is offline  
post #6 of 9 (permalink) Old Apr 9th, 09, 05:15 PM
Gold Lifetime Member
Mike
 
prostreet69camaro's Avatar
 
Join Date: Jul 2003
Location: Spring Texas
Posts: 5,580
Re: Headlights only work on High Beam

Take a test light and check to see if you have power on the high beam wires. If the test light lites up then it is the bulbs.

Make sure the connector on the dimmer switch is connected good and no burnt terminals also. You can also push the dimmer switch back and forth to check both circuits.

Mike
69 Camaro Prostreet - purple w/ghost flames , 502 w/ 871 blower


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
prostreet69camaro is offline  
post #7 of 9 (permalink) Old Apr 9th, 09, 09:43 PM
Gold Lifetime Member
Jeff
 
yellow69RS's Avatar
 
Join Date: Jul 2007
Location: Aurora, IL
Posts: 5,270
Send a message via Yahoo to yellow69RS
Re: Headlights only work on High Beam

I'm bettin money that both low beams are out. But check all the connections at the lights and dimmer for corrosion.

Jeff
yellow69RS is offline  
post #8 of 9 (permalink) Old Apr 17th, 09, 06:09 PM
Dave
 
Join Date: Feb 2009
Location: SoCal
Posts: 10
Re: Headlights only work on High Beam

Be sure the wires are in the correct position on the dimmer switch. I'm doing this from memory: Lt grn and Tan are on the outside, yellow in the middle.

If your lt grn wire is in the middle, this is your problem.
DaveP. is offline  
post #9 of 9 (permalink) Old Apr 17th, 09, 06:51 PM
Tech Team
Howard
 
Join Date: Feb 2009
Location: Va. Beach, Va.
Posts: 92
Re: Headlights only work on High Beam

A friend of mine had this problem too.We also thought there was a bad ground,but after checking all wires,there was a bad connection at the firewall main connecter.Cleaned all terminals and fixed the problem.

Just Having fun with all My Big Block Toys!!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bbmusclecars427 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome