Electrical Snafu - 69 Camaro Z-28 RS - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old May 30th, 09, 09:30 PM Thread Starter
 
Join Date: May 2009
Posts: 3
Angry Electrical Snafu - 69 Camaro Z-28 RS

After a 4 year old frame off restoration my turn signal have suddenly quit working. The snafu - when applying the brakes, both R & L dash turn indicators come on at the same and the front R & L turn signals come on at the same time as the brake lights. I have changed all of the fuses and have changes the flasher to no avail. I have looked at the wiring diagrams and can only sumize the turn swith is bad. Any suggestions?
ezriderok is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old May 30th, 09, 09:48 PM
Gold Lifetime Member
Jeff
 
yellow69RS's Avatar
 
Join Date: Jul 2007
Location: Aurora, IL
Posts: 5,142
Send a message via Yahoo to yellow69RS
Re: Electrical Snafu - 60 Camaro Z-28 RS

the hazard switch is related to this problem somehow, or maybe the wrong bulbs some where. My first thing is to check hazard operation and go from there.

Jeff
yellow69RS is offline  
post #3 of 7 (permalink) Old May 30th, 09, 09:58 PM Thread Starter
 
Join Date: May 2009
Posts: 3
Re: Electrical Snafu - 60 Camaro Z-28 RS

That sounds logical. I will change the hazard flasher. All of the bulbs appear to work, but I could change them, too. Thanks.
ezriderok is offline  
 
post #4 of 7 (permalink) Old Jun 2nd, 09, 03:17 PM
bill
 
Join Date: May 2003
Location: AZ
Posts: 28
Re: Electrical Snafu - 69 Camaro Z-28 RS

check the brake light switch down by the peddle. I had similiar things happen and mine was just loose.

Bill.

69 z/28 rs cortez silver, black top, dlx blue int 9N631044/9N631043
yenko deuce
68 427 nova
57's
bilede is offline  
post #5 of 7 (permalink) Old Jun 2nd, 09, 04:22 PM
Gold Lifetime Member
kevin
 
67conv.cam's Avatar
 
Join Date: Aug 2008
Location: mobile al
Posts: 601
Re: Electrical Snafu - 69 Camaro Z-28 RS

our electrical gremlins on our 72 came from bondo dust all inside... found its way into connectors ..never thought it could...i agree something is loose or corroded..causing feedback...
67conv.cam is offline  
post #6 of 7 (permalink) Old Jun 6th, 09, 10:11 AM Thread Starter
 
Join Date: May 2009
Posts: 3
Re: Electrical Snafu - 60 Camaro Z-28 RS

Quote:
Originally Posted by yellow69RS View Post
the hazard switch is related to this problem somehow, or maybe the wrong bulbs some where. My first thing is to check hazard operation and go from there.

Jeff
Thanks yellow69RS !! Unbeknown to me "someone" pushed in my Hazard knob (I don't have a Hazard Flasher so the lights don't "flash") thereby creating a pass thru. Simple fix !! Thanks again!!
ezriderok is offline  
post #7 of 7 (permalink) Old Jun 6th, 09, 11:21 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,854
Garage
Re: Electrical Snafu - 69 Camaro Z-28 RS

Don'cha love those simple fixes?

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome