1968 camaro turn signal problem - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Aug 15th, 09, 06:45 PM Thread Starter
Senior Tech
 
knightmoose's Avatar
 
Join Date: Mar 2004
Location: Los Angeles California
Posts: 620
1968 camaro turn signal problem

I have an all origibnal everything 68 camaro, my left turn signal when you turn it on stays solid trangle green and doesnt blink... I thought it was the bulb so i replace both the front and rear bulbs and get the same result..

with no turn signal on when i turn on the head lights the left turn signal illuminates solid green, i just cant seem to find out where the short is actually at? im certain its on the left side lol becaus eevertything works on the right side, i just dont know? any suggestions? maybe a bad ground or something?

it about helping others
knightmoose is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Aug 16th, 09, 03:58 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,651
Garage
Re: 1968 camaro turn signal problem

Up front, follow the ground wire back to the radiator support and clean the terminals and area.
At the rear, make sure the sockets are making a good connection in the light fixture as well as a good connection of the bulbs in their sockets.
Of course, you've changed the bulbs with the same number both front & rear.
You might even pull out the socket, remove the bulb, and push out the center pins and lengthen the spring alittle. Wire brushing things might not hurt either.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden … enjoy your next chapter.
Everett#2390 is offline  
post #3 of 8 (permalink) Old Aug 18th, 09, 07:54 PM Thread Starter
Senior Tech
 
knightmoose's Avatar
 
Join Date: Mar 2004
Location: Los Angeles California
Posts: 620
Re: 1968 camaro turn signal problem

hmm the wire at the radiator was broken i tried to reground agian and i still have the same problem, somewehere their is a serious short

it about helping others
knightmoose is offline  
 
post #4 of 8 (permalink) Old Aug 18th, 09, 09:02 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,651
Garage
Re: 1968 camaro turn signal problem

Do the emergency flashers work at all four corners?
The flashers use the same bulb filament as the brake/turn signal lights.

You might substitute a heavy duty flasher as the h/d flasher times itself to flick on/off and does not depend on bulb resistance to flash as a standard flasher does. More commonly known as a trailer light flasher, P/N 552 as opposed to a 512?

With the turn signal indicator coming on with headlights on signifies a faulty ground path, hence the t/s indicator coming on or a miswire between the headlights and turn signals, maybe a parking light wire, brown(?), misplaced?

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden … enjoy your next chapter.
Everett#2390 is offline  
post #5 of 8 (permalink) Old Oct 16th, 12, 12:38 PM
rich
 
Join Date: Oct 2012
Location: mass
Posts: 1
Re: 1968 camaro turn signal problem

had same problem found back side of d/s plug (for bulb) to be all messed up the short is in the socket or harness up front. could be turn signal indicator but rare to find
rs salvati is offline  
post #6 of 8 (permalink) Old Oct 16th, 12, 05:42 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,651
Garage
Re: 1968 camaro turn signal problem

Welcome, Rich. Glad to have you here.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden … enjoy your next chapter.
Everett#2390 is offline  
post #7 of 8 (permalink) Old Oct 17th, 12, 04:46 PM
Team Member
Dave
 
USN1969SS's Avatar
 
Join Date: Jul 2003
Location: Viera, FL
Posts: 286
Re: 1968 camaro turn signal problem

I had the same issue in my 69, took the turn signal and idiot lights out from under the dash, cleaned all the bulb connections with a file and problem fixed. As the others have mentioned, you have a bad connection somewhere. A dirty connection can cause an increase in impedance and although the lamps work, can cause a problem.

1969, 350 "Beast", M20, Nothing Fancy, Nothing Pretty, But Sure is Fun!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
USN1969SS is offline  
post #8 of 8 (permalink) Old Oct 17th, 12, 05:40 PM
Senior Tech
 
Join Date: May 2004
Location: Southeast PA
Posts: 8,303
Re: 1968 camaro turn signal problem

Other than the last four posts (incl this one) this thread was three years old...

Eric
69 'vert project big block/TKO 600 RR
68 'vert driver RS clone -- gone!
Eric Kammerer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome