MSD6-AL2 problems! Need experienced help! - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Sep 6th, 09, 02:43 PM Thread Starter
Senior Tech
 
Join Date: May 2008
Location: South FL
Posts: 119
MSD6-AL2 problems! Need experienced help!

So basically took the valves off, took the coil wire off, adjusted valves (the coil did spark while doing the valve adjustment). Put on new gaskets and valve covers all tightly sealed, nice and neat, GM performance valve covers and everything.

Buuuut...car doesn't start now. It did run yesterday just to be clear. Mechanic came over and was helping me go through it, pulled the MSD box and the LED light is blinking red 3 times, pausing, blinking red 3 times again. I can't find exactly what this indicates and the MSD website doesn't tell me exactly what this means. Anyone got any ideas?

My mechanic followed the manual for the 6AL2 (here it is http://msdignition.com/instructions/...pdf?terms=6421 ) and looking at page 9 created the short and got a successful spark from the coil. Buttttt the engine still does not start. Whats going on?
rideelement247 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Sep 6th, 09, 03:17 PM
Gold Lifetime Member
Mike
 
prostreet69camaro's Avatar
 
Join Date: Jul 2003
Location: Spring Texas
Posts: 5,580
Re: MSD6-AL2 problems! Need experienced help!

I would check the dist cap and rotor. I went to a cruise once and my car would not start. I did the test on the msd box and had spark to the coil wire. Still would not start. Pulled the cap off and the tip of the rotor was broken and turned side ways.

But I have the MSD 6AL.

Mike
69 Camaro Prostreet - purple w/ghost flames , 502 w/ 871 blower


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
prostreet69camaro is offline  
post #3 of 3 (permalink) Old Sep 7th, 09, 02:40 PM
Gold Lifetime Member
Skip
 
Skeeter55's Avatar
 
Join Date: Feb 2008
Location: CA
Posts: 6,628
Re: MSD6-AL2 problems! Need experienced help!

Sounds like you spiked the box..

I NEED TO HIT THE LOTTERY
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Skeeter55 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome