69 Horn Relay problem - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Dec 2nd, 09, 10:57 AM Thread Starter
 
Join Date: Dec 2009
Posts: 13
69 Horn Relay problem

Hi everybody. I am new to this site and it looks awesome. I am replacing the turn-signal assembly and after installing and hooking up the harness my Horn Relay now emits a loud buzzing noise. This noise stops when I unplug the Hot wire from the relay that is coming from the steering column.

Does the horn Relay just need to be replaced???

Kent
kkeller73703 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Dec 2nd, 09, 11:18 AM
Senior Tech
Trevor
 
Join Date: Mar 2008
Location: Red Deer, Alberta
Posts: 120
Re: 69 Horn Relay problem

I had that problem as well,It was contact chatter. I had to bend the contact arm open a bit. Do this with the battery disconnected.

1969 SS 454ci TKO 600
Alberta69SS is offline  
post #3 of 5 (permalink) Old Dec 2nd, 09, 11:23 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,661
Garage
Re: 69 Horn Relay problem

The buzz can also be "Key-in-the-ignition." Remove the keys or the pink wire to disable forever, at least until the pink wire is plugged back in.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
 
post #4 of 5 (permalink) Old Dec 2nd, 09, 11:59 AM Thread Starter
 
Join Date: Dec 2009
Posts: 13
Re: 69 Horn Relay problem

Hey thanks! The problem persists when the key is in the ignition AND the car is running???? So not sure about the "key-in" possibility....
kkeller73703 is offline  
post #5 of 5 (permalink) Old Dec 2nd, 09, 12:03 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,661
Garage
Re: 69 Horn Relay problem

Only with the ignition off and key in the ign/tumbler should the buzzer be buzzin'.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome