69 Positive cable clips???? - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jan 4th, 10, 11:46 AM Thread Starter
Ron
 
Join Date: Nov 2009
Location: Motor City
Posts: 14
69 Positive cable clips????

Does anyone know how to install the clips to the frame that holds the positive cable, there are 1/4" holes and the new clips I have have a rivet that is snug in the hole but how is this secured???? Thanks in advance, Ron
$uper$port is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jan 4th, 10, 12:45 PM
Gold Lifetime Member
Fred
 
Join Date: Nov 2006
Location: Seabeck WA
Posts: 8,375
Re: 69 Positive cable clips????

Welcome Ron!
I've never removed the positive clips. They should just pop into the frame and stay put. Here's mine. The clip is in the center of the picture. The other one is not shown but it's near the starter. The correct holes should work with no other retainers. Remember; "assembly lines". Gotta be quick, but most of all not challenging to workers.

One owner 69 Camaro,(yep, bought it new
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
RS SS Hugger Orange, L88, 4:10's tru-tack posi, ducted hood, Endura, spoilers.
TH400 (CX) with Coan 8" converter, GV-OD, 8 track still on console and best et 10.495,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
128.79mph 1.428 60'
All with 1960's stuff. (except tires and converter)
+ MT Super Scavenger headers & 3" full exhaust with X pipe. 3700 lbs. with me in it.
1000cfm AED and HD Harold-Lunati SR, 725 lift with shaft rockers too.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Fred Ficarra is offline  
post #3 of 4 (permalink) Old Jan 9th, 10, 09:44 AM
Senior Tech
 
Join Date: Mar 2002
Location: Houston, Texas U.S.
Posts: 683
Re: 69 Positive cable clips????

I've ruined a few of these clips trying to install them. Have never figured it out. It's almost like you need a punch where the tip expands when it is inserted into the middle of the rivet hole attached to the clip.

EricE
68 Butternut Yellow
SS Coupe 396/325
stope4 is offline  
 
post #4 of 4 (permalink) Old Jan 10th, 10, 07:30 PM
Gold Lifetime Member
Roger
 
rogerh's Avatar
 
Join Date: Oct 2004
Location: Quincy, IL
Posts: 18,720
Re: 69 Positive cable clips????

What I did was to use a pop-rivet inside the clip fastener. I cut the barrel from another pop-rivet to use as a spacer to go through the clip. The pop-rivet expanded the clip fastener and it seems to be holding.

Roger

1967 Camaro SS/RS 350/295HP Coupe. First and only owner.
rogerh is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome