Horn / Steering wheel problem - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jan 31st, 10, 10:41 AM Thread Starter
Senior Tech
H
 
Join Date: Jan 2009
Location: BC, Canada
Posts: 326
Horn / Steering wheel problem

Hey guys, I recently installed my new steering wheel, and I connected the two wires for the horn. When i hooked up my battery and turned the car back on, everytime the steering wheel moves, the horn goes off. I took the steering wheel off, checked the wires and everything looks fine. What could be the problem? Should I just unhook it as im going to be using a different button for my horn anyways?
250motorsportz is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Feb 2nd, 10, 07:22 AM
gmc
Gary
 
Join Date: Aug 2009
Location: NC
Posts: 25
Re: Horn / Steering wheel problem

Do you still have the lock plate and retainer installed? I had a similar issue, if I pushed on the wheel the horn would sound and my signals wouldn't cancel. Someone had removed the lock plate and retainer from my column.
gmc is offline  
post #3 of 4 (permalink) Old Feb 2nd, 10, 11:13 AM
Gold Lifetime Member
Steve
 
foreverlookin's Avatar
 
Join Date: Oct 2002
Location: Pflugerville, Texas
Posts: 1,753
Garage
Re: Horn / Steering wheel problem

What year/make car?

Steve
The best laid plans are those not made (mine)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
foreverlookin is offline  
 
post #4 of 4 (permalink) Old Feb 2nd, 10, 11:56 AM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,316
Re: Horn / Steering wheel problem

Is the insulation tube on the horn ire/spring set right and in good condition?

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome