Dash and running lights not working - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old May 17th, 10, 11:07 AM Thread Starter
Jerry
 
Join Date: May 2010
Location: Burson, Ca
Posts: 5
Dash and running lights not working

I have a 69 standard coupe with V8350 automatic. It is in running condition till I can start resto. Recently the dash and running lights quit working. I replaced the light switch, no better. All fuses good. I can remove the connector to the switch and using a jumper wire can get all the lights to function. What am I missing?
69newbie is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old May 17th, 10, 02:10 PM
Senior Tech
Kevin
 
sleepsinshed's Avatar
 
Join Date: May 2004
Location: Bad Roads, MA
Posts: 2,410
Re: Dash and running lights not working

When you say running lights, do you mean parking/headlights? I just fixed a similar problem where the dash lights went out due to a short that was caused by a defective headlight switch. Since you can manually get the lights to work when by-passing the switch, my guess is you have a bad or missing ground somewhere. It never hurts to make up a wire with some terminal ends that you can use to run a ground to the dash flex board.

Kevin

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
sleepsinshed is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome