Another turn signal problem? - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old May 27th, 10, 07:10 PM Thread Starter
Senior Tech
Jeremiah
 
Join Date: Jul 2006
Location: Oklahoma
Posts: 1,111
Another turn signal problem?

When you hit the turn signal on the wifes 69 RS it will flash approx 15 times and go dead. You can cancel it and and hit it again and the same thing. The brake lights, head lights and tails work fine but the front lights work sometimes.

Can anyone tell me exactly where to locate/check for proper grounds for this problem?

69 Z/28, red/white stripe, black houndstoot with docs.
Jeremiah is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old May 27th, 10, 10:20 PM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,316
Re: Another turn signal problem?

Sounds more like the toe in has been done on a wheell alignment has been done THEN the steering wheel forced onto the column to center it...
The steering wheel needs to be centered, assuming it has been located on the collumn correctly THEN the wheel alignment set.
Covered in detail in a thread in the last couple days

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
post #3 of 4 (permalink) Old May 28th, 10, 04:21 AM
Moderator
Guess
 
HwyStarJoe's Avatar
 
Join Date: Jan 2001
Location: New Taxes York
Posts: 15,365
Re: Another turn signal problem?

For $3, pick up a new flasher while you're out and about this weekend.
Part Number: FL552/536

*---------------------------------*


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

HwyStarJoe is offline  
 
post #4 of 4 (permalink) Old May 28th, 10, 07:23 PM
Tech Team
Mark
 
Join Date: Oct 2007
Location: Houston, Texas
Posts: 51
Re: Another turn signal problem?

Did not want to start a new post since there seems to be so many on this top. I have replaced the flasher with a 552 replacement, bulbs are all O.K. on four corners but the turn signal does not want to flash. What's going on in my 67 Camaro?
gearheadtx is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome