Instrument bezel and light socket question - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Feb 19th, 11, 03:55 PM Thread Starter
Senior Tech
 
Join Date: Feb 2009
Location: Illinois
Posts: 100
Instrument bezel and light socket question

I am installing the insturment cluster in my 69 and have a couple questions.

Heres a little backgroud info: The insturment cluster (bezel, gauges, etc) are new repos. I added the tach and clock option also. The wiring is new also. It is an American Auto Wire, factory fit harness.

Thr dash harness is installed, I am about to install the insturment cluster and am plugging all the connectors to the back of the cluster.
My first question is: do you install the dash pad before the cluster or after the cluster is in place?
Second: is a little complicated, I am trying to figure out which of the light sockets on the AAW harness get plugged into the top of the Tach housing area and the top of the Speedometer housing area. There is also a clock which needs a light socket to it. I looked the AAW harness over and there are light sockets but I see two that fit the clock housing and one that fits the tach or speedometer housings. I need two for the tach and speedometer housings and one for the clock. I am trying to figure out if I am doing something wrong or the harness is wrong.
If anyone can post a picture of an original tach/clock insturment cluster and harness it would be a great help. Thanks
justsomeguy is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Feb 19th, 11, 04:10 PM
Senior Tech
Jeremie
 
Join Date: Oct 2010
Location: Hot Springs, AR
Posts: 492
Re: insturment bezel and light socket question

I put dash pad on last. In regards to the lights, there should be 3. Each gauge, or clock has a hole on the top that will fit only one light. It really doesnt matter which bulb goes where as they all turn on at the same time. I dont have any pics but I did my conversion a few months ago
MTN10 is offline  
post #3 of 3 (permalink) Old Feb 20th, 11, 05:22 PM Thread Starter
Senior Tech
 
Join Date: Feb 2009
Location: Illinois
Posts: 100
Re: Instrument bezel and light socket question

Thanks. I installed it today and after a bit of tweaking, got everything hooked up. I had the dash pad on already so I took it back off and did the cluster. Did not get the dash pad back on, do that in the morning.

Thanks again
justsomeguy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome