Turn signal= hazards mayhem - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jun 8th, 11, 08:42 AM Thread Starter
 
Join Date: Mar 2009
Location: Florida
Posts: 5
Turn signal= hazards mayhem

I just bought a 1979 Z28 and it has a few issues to say the least. Right now im focused on the fact that when I use my turn signal it acts as if i had engaged the hazard flashers. When I try to use the hazards directly nothing happens. I am confused as to how this would occur and I'm stuck as to how to fix it. I don't know what causes this so I don't know what to check for.
K102 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jun 8th, 11, 12:54 PM
Gold Lifetime Member
Larry
 
Join Date: Oct 1999
Location: Alamogordo, NM, USA
Posts: 1,026
Re: turn signal= hazards mayhem

I guess we can start by seeing if the hazard flasher is installed and that the brake fuse, (which powers the hazards) is good.

Does the under dash wiring look like it has been messed with or butchered? I can't think of anything off the top of my head that would cause this from a simple malfunction of a part unless the harness has been modified. OK, maybe the turn signal switch might be at fault here. But, we need to see if there are simpler solutions before that's changed out.

Current Project:
69 Z/28 Resto-Mod
Next In Line:
83 Z28 Restoration
69-er is offline  
post #3 of 4 (permalink) Old Jun 8th, 11, 06:08 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 32,025
Garage
Re: turn signal= hazards mayhem

Hazard switch turned off?

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
 
post #4 of 4 (permalink) Old Jun 13th, 11, 11:14 PM Thread Starter
 
Join Date: Mar 2009
Location: Florida
Posts: 5
Re: Turn signal= hazards mayhem

I checked the wires underneath and it looked alright just missing a hazard flasher. I pulled off the steering wheel and I noticed the hazard directional had jammed itself in the on postion. So I tweaked it off and now the directional work! The hazards created a closed circut taking power from the directional switch i guess as they only work when I put on the hazards and use my directionals. Thank you everyone for the thoughts!
K102 is offline  
Sponsored Links
Advertisement
 
Reply

Tags
flashers, hazard, turn signal

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome