Wipers only work when pressing washer button. - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 2Likes
  • 2 Post By hsjnlssmith
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old Dec 30th, 11, 10:28 PM Thread Starter
Senior Tech
Greg
 
Join Date: Oct 2011
Location: Michigan
Posts: 112
Wipers only work when pressing washer button.

I've got a brand new wipers system- wiper motor, washer pump, and switch. Nothing happens when I twist the wiper switch, but the wipers will work while I hold the washer button, so I bought a new switch and it still does it. Any suggestions?
Whysohigh is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old Dec 31st, 11, 12:07 AM
Senior Tech
Sean
 
Join Date: Feb 2002
Location: N.W. Washington
Posts: 7,962
Re: Wipers only work when pressing washer button.

Is this a 67-68? If so I would guess you are not getting a good ground at the switch, it needs to have a good clean contact where it attaches to the dash. Mine did the same thing when I bought the car and the P/O had ground straps and crap all over, I just cleaned the contact surface and it worked fine. The other guess would be the switch but sounds like that is new.

Sean

1968 rs with an old school 354" SB2.2 pump gas motor.

Repetition does not transform a lie into a truth.

Franklin D. Roosevelt
68rs406 is offline  
post #3 of 11 (permalink) Old Dec 31st, 11, 07:41 AM Thread Starter
Senior Tech
Greg
 
Join Date: Oct 2011
Location: Michigan
Posts: 112
Re: Wipers only work when pressing washer button.

Yes its a 67, and thanks I'll clean up the surface and try it. I suspected that and ran a wire from a good ground to the switch but nothing changed. I'll pull it tonight and give it a try thanks.
Whysohigh is offline  
 
post #4 of 11 (permalink) Old Dec 31st, 11, 08:02 AM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,481
Garage
Re: Wipers only work when pressing washer button.

It sounds like the washer pump and wiper leads are reversed but bad grounds have caused more gremlins in these old cars than AMC built so give Seans suggestion a try.

...Dennis

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Don't take life so serious, you won't get out alive..."
DjD is offline  
post #5 of 11 (permalink) Old Jan 7th, 12, 07:32 AM Thread Starter
Senior Tech
Greg
 
Join Date: Oct 2011
Location: Michigan
Posts: 112
Re: Wipers only work when pressing washer button.

Well its definitely getting a good ground.

67 454 Edelbrock air cleaner, performer carb, intake, heads & shocks. headers to 3" duals, HID 85K headlights, custom motorcycle twist throttle controls (paralyzed waist down), all new interior
Whysohigh is offline  
post #6 of 11 (permalink) Old Jan 16th, 12, 04:22 PM Thread Starter
Senior Tech
Greg
 
Join Date: Oct 2011
Location: Michigan
Posts: 112
Re: Wipers only work when pressing washer button.

Correct you are DJD, the leads were on wrong. I can see clearly now.... Thanks again.

67 454 Edelbrock air cleaner, performer carb, intake, heads & shocks. headers to 3" duals, HID 85K headlights, custom motorcycle twist throttle controls (paralyzed waist down), all new interior
Whysohigh is offline  
post #7 of 11 (permalink) Old Jan 16th, 12, 06:01 PM
Senior Tech
Sean
 
Join Date: Feb 2002
Location: N.W. Washington
Posts: 7,962
Re: Wipers only work when pressing washer button.

Nice! Sometimes it's the easiest thing, thanks for posting back the solution!

Sean

1968 rs with an old school 354" SB2.2 pump gas motor.

Repetition does not transform a lie into a truth.

Franklin D. Roosevelt
68rs406 is offline  
post #8 of 11 (permalink) Old Apr 22nd, 17, 02:51 PM
Probationer
Hank
 
Join Date: Apr 2017
Location: Katy, TX
Posts: 5
Re: Wipers only work when pressing washer button.

I know this is an old post, but it is exactly the problem I am having. I do not fully understand what is meant by reversing the leads? I am attaching a photo of my set-up and maybe you can help me understand more specifically what I need to reverse.

Thanks, Hank
Attached Thumbnails
Click image for larger version

Name:	20170422_162528_resized.jpg
Views:	235
Size:	85.7 KB
ID:	181418  
hsjnlssmith is offline  
post #9 of 11 (permalink) Old Apr 23rd, 17, 06:00 PM
Andy
 
Join Date: Apr 2017
Location: Washington State
Posts: 1
Re: Wipers only work when pressing washer button.

I am pretty sure the brown connector should be swapped with the pigtail black one. Brown to Motor and Black to washer pump.
elocam1968 is offline  
post #10 of 11 (permalink) Old Apr 25th, 17, 06:41 PM
Probationer
Hank
 
Join Date: Apr 2017
Location: Katy, TX
Posts: 5
Thanks, but I looked a bit closer and found that the brown connector only fits on the squirter pump it is larger than the black one. So, I'm fairly certain the wiring is right. If there was a ground issue with the wiper switch, them wouldn't it also be an issue when trying to operate the wiper in squirter mode? In other words, if the wiper does not come on in just wiper mode due to a ground problem, then it should not come on in squirter mode. The wipers do come on in squirter mode. Is that logical. If so, I am figuring that the switch has gotten tired and needs replacing. Thoughts?
hsjnlssmith is offline  
post #11 of 11 (permalink) Old Jun 4th, 17, 12:30 PM
Probationer
Hank
 
Join Date: Apr 2017
Location: Katy, TX
Posts: 5
Ok, just wanted to close this issue out. Ended up buying a new wiper switch. Replaced the old one this weekend and everything in the world is right again! What a relief! Cheers to all. Henry
DjD and 69-Pace like this.
hsjnlssmith is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome