69 Hazard Light Button Issue - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old Mar 15th, 12, 09:34 AM Thread Starter
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Exclamation 69 Hazard Light Button Issue

My Hazard Switch is malfunctioning:
Left & Right turn signal indicators work.
Front and back turn lights blink.
I even swapped the flasher unit between signals and hazards with no change so the issue is the button.

Hazard switch started to pop out on its own last year and now most of the time won't lock in the depressed "on" position.

Also now even if you can get the button to lock or you hold it by hand, the right indicator on the dash won't light or flash, but the front & rear left and right lights are flashing.

So I assume that the hazard switch needs to be removed and replaced. Don't think I can service from outside column. I hate steering column work so I want to make sure I don't miss anything in replacing the switch. Anyone have any good pictures of this job?

I think I will need to do the following looking at the AIM:
Pull the wheel
Pull the horn button guts
Pull the turn signal cancel cam.
Now is where I'm worrying. Never been deeper then this so what are the next parts to come out - ignition switch or can that stay in?

Thanks


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old Mar 15th, 12, 09:46 AM
Moderator
Guess
 
HwyStarJoe's Avatar
 
Join Date: Jan 2001
Location: New Taxes York
Posts: 15,365
Re: 69 Hazard Light Button Issue

Ignition switch can stay.

You're right that the turn signal cam has to come out... it's also the hazard switch.
When you press down on on the hazard button, there's a curved flat spring that depresses and makes the button pop back up. The button itself is attached to a square black plastic piece that 'snaps' in or out, depending on whether you push or pull the button. That piece is probably you're problem.

*---------------------------------*


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

HwyStarJoe is offline  
post #3 of 10 (permalink) Old Mar 15th, 12, 09:59 AM Thread Starter
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: 69 Hazard Light Button Issue

Joe so if that part is the issue, I have to replace the turn signal cam. Are the reproduction prone to any fitment issues?

And am I right in assuming that if the turn signal wiring is fine, turn signal indicator works, that the hazard switch uses the same connection and its just that the "spring" is not contacting all the leads at the hazard switch part or may I still have a wiring issue on the hazard side.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
 
post #4 of 10 (permalink) Old Mar 15th, 12, 10:22 AM
Gold Lifetime Member
Jeff
 
yellow69RS's Avatar
 
Join Date: Jul 2007
Location: Aurora, IL
Posts: 5,011
Send a message via Yahoo to yellow69RS
Re: 69 Hazard Light Button Issue

The Hazard switch is part of the turn signal switch, not the cam. I'm sure that's what Joe menat to say needs to be replaced. The T/S switch is all the deeper you need to go but you have to undo the column mount bracket at the dash to get the wires thru.

Jeff
yellow69RS is offline  
post #5 of 10 (permalink) Old Mar 15th, 12, 11:17 AM
Moderator
Guess
 
HwyStarJoe's Avatar
 
Join Date: Jan 2001
Location: New Taxes York
Posts: 15,365
Re: 69 Hazard Light Button Issue

That's what I meant.
It's possible to have a wiring issue... I'll bet the wires are all dried and cracked at the switch. The factory puts some serious bends in the harness which doesn't help matters.

You'll see what we're talking about once you get the steering wheel off and the rest of the upper column parts.
Here's Jim Shea's Steering Papers, all about the column and parts break-downs with pictures: http://jimshea.corvettefaq.com/?cat=4

*---------------------------------*


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

HwyStarJoe is offline  
post #6 of 10 (permalink) Old Mar 15th, 12, 02:13 PM Thread Starter
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: 69 Hazard Light Button Issue

Okay if I can find my wheel pull I'll dig into it this weekend. Thanks.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
post #7 of 10 (permalink) Old Mar 15th, 12, 06:07 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,657
Garage
Re: 69 Hazard Light Button Issue

Visit Harbour Freight, both the wheel puller and lock ring plate pusher for under $20(?), maybe $10.
I bought the pusher for $2 and worth every penny of it. Use a scribe to remove the retaining ring.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
post #8 of 10 (permalink) Old Mar 18th, 12, 08:23 AM Thread Starter
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: 69 Hazard Light Button Issue

Thanks Everett - Think I loaned mine out a few years ago and it never returned to my tool box for some reason. Guess the price is right.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
post #9 of 10 (permalink) Old Mar 18th, 12, 06:54 PM
Gold Lifetime Member
Mike
 
prostreet69camaro's Avatar
 
Join Date: Jul 2003
Location: Spring Texas
Posts: 5,580
Re: 69 Hazard Light Button Issue

When you pull the wiring plug thru you're column tape a piece of wire to it for a pull wire to pull the new plug thru.

Mike
69 Camaro Prostreet - purple w/ghost flames , 502 w/ 871 blower


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
prostreet69camaro is offline  
post #10 of 10 (permalink) Old Mar 18th, 12, 09:50 PM Thread Starter
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: 69 Hazard Light Button Issue

Thanks Mike for the tip


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome