67 charging issues - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Aug 31st, 12, 08:39 AM Thread Starter
Senior Tech
frank
 
Join Date: May 2004
Location: toronto
Posts: 144
67 charging issues

I own a 67 rsss rag with console guages. I noticed that my guage was barely over on the charging side. Sure enough, i do a 3 hour cruise and notice lights are starting to dim; decide to try my horn, and it is muted....rush home, turn off car, try to restart, nadda! Ok, so take out battery, get it checked, all ok. Take out Alternator, get it checked, all ok. So independentally, all ok. Alternator shop guy says to me, this is alternator has a built in regulator and asks if I am running a separte regulator. I said yes. So he says that why its not charging, and tells me to disconnect the wires from regulator to the back of alternator and run a wire direct from positive battery to back of alternator. I did that but need to check to see if charging properly.
So my question is two fold....is his synopsis correct? And, my charging guage in console hasnt moved up to the 3/4 + side, but still just past center to positive side. And what do I do with those wire from the regulator, one is a female connector, and the other that went to the back of the alternator.
Oh, and one other thing about the alternator connector. I turned my key to the on positions and took a test light to the connector...only on side of the connector showed power??
Sorry for such a long read, but I am not an electrical diagnostic-er and any help is appreciated. Happy safe Labor Day crusing everyone.
viper is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Aug 31st, 12, 08:48 AM
Senior Tech
Camarodude67
 
Join Date: May 2005
Location: Hartford, CT
Posts: 2,289
Re: 67 charging issues

You have to remove the connector from the external voltage regulator and jump
the pins together, I have a picture for you. I just did this for my 67 RS Convertible and charges no problem.

I need your e-mail address.

Jeff G.
camarodude67 is offline  
post #3 of 5 (permalink) Old Aug 31st, 12, 08:54 AM Thread Starter
Senior Tech
frank
 
Join Date: May 2004
Location: toronto
Posts: 144
Re: 67 charging issues

Camaro dude, thank you for the [email protected]
viper is offline  
 
post #4 of 5 (permalink) Old Aug 31st, 12, 10:24 AM
Senior Tech
Camarodude67
 
Join Date: May 2005
Location: Hartford, CT
Posts: 2,289
Re: 67 charging issues

Sent 3 pictures.

Jeff G.
camarodude67 is offline  
post #5 of 5 (permalink) Old Sep 1st, 12, 03:20 AM
Senior Tech
Steve
 
Join Date: Jun 2005
Location: Melbourne, Australia
Posts: 2,864
Re: 67 charging issues

Get one of these external to internal reg adaptors..
It also converts the alternator's Si plug to a Dn. No mods required.

http://www.heartbeatcitycamaro.com/s...conv-67-68-69/

Nov 68 Van Nuys. 327 floor-shift-auto, Frost Green and not much else when new.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BlackoutSteve is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome