67 tailight fuse - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Sep 8th, 12, 10:06 PM Thread Starter
Gold Lifetime Member
jared
 
Join Date: Sep 2008
Location: Fairfax, Mo
Posts: 1,097
67 tailight fuse

When I hold on the brakes for a real long time,like 5 min the fuse blew ,but this is the 2nd time it's done it. The fuse I pulled out was a 15 amp , so it was a little under rated ! What size of fuse are you guys running ???? I also have some other things plugged into the open spots on the fuse panel, like tach light,water, temp, volt lights on one open spot ,and stereo, tach hot wire on the other.I'm sure the extra lights would put more of a load on the fuse. Also I'm not sure what size of fuse I should run. The lettering is rubbed off. I did do a search ,but only found one thread that said it should be a 20 amp fuse,so I wasn't sure .
jcfcamaro is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Sep 9th, 12, 04:22 AM
Gold Lifetime Member
Mike
 
prostreet69camaro's Avatar
 
Join Date: Jul 2003
Location: Spring Texas
Posts: 5,580
Re: 67 tailight fuse

20 amp

Mike
69 Camaro Prostreet - purple w/ghost flames , 502 w/ 871 blower


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
prostreet69camaro is offline  
post #3 of 5 (permalink) Old Sep 9th, 12, 02:41 PM Thread Starter
Gold Lifetime Member
jared
 
Join Date: Sep 2008
Location: Fairfax, Mo
Posts: 1,097
Re: 67 tailight fuse

would a 20 amp be enough with the extra lights im running
jcfcamaro is offline  
 
post #4 of 5 (permalink) Old Sep 9th, 12, 05:11 PM
Gold Lifetime Member
Mike
 
prostreet69camaro's Avatar
 
Join Date: Jul 2003
Location: Spring Texas
Posts: 5,580
Re: 67 tailight fuse

I would try it. The problem is the original wiring is only rated for 20 amps.

It would be nice if you had a DC amp meter to check the total amperage. Then you could see if you are exceeding the 20 amps.

Mike
69 Camaro Prostreet - purple w/ghost flames , 502 w/ 871 blower


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
prostreet69camaro is offline  
post #5 of 5 (permalink) Old Sep 10th, 12, 07:12 PM
Senior Tech
 
Join Date: Oct 2006
Location: Canada
Posts: 4,942
Re: 67 tailight fuse

Be sure and really, and I mean really check out the fitting of those bulb holders and how they are sitting in the sockets. I had the same prob this year, and found that one wasn't seated correctly, and it seemed to be the cause of the fuses blowing on me. I also reinforced the wires coming into the back lights...they tend to get knocked about, esp if you have lots of stuff in the back as I do, eh?

capt

Bumper sticker- I'm not SPEEDING
I'm QUALIFYING!
captcanuck68 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome