Why is my Alt. light on - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old Sep 22nd, 12, 08:23 PM Thread Starter
 
Join Date: Oct 2003
Location: Idaho
Posts: 16
Why is my Alt. light on

I have a 68 Camaro and I just put in a 700-R4 tranny in it the other day and whether this has any thing to do with it I'm not sure. My alt. light came on but it's very dim. I checked the battery and it handles the load test ok. the Alt. it putting out 14 amps. I put in a new battery and when I started it up the light is still on. I have driven the car about 40 miles with the lights mostly on bright and the lights are as bright as every. Does anyone have any ideas for me.
Thanks,
Rich
srtmember is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old Sep 22nd, 12, 08:35 PM
Senior Tech
Paul B
 
Join Date: Jul 2012
Location: Ontario
Posts: 273
Re: Why is my Alt. light on

I had a similar problem a few weeks ago. In my case it was simply a matter of the wire that leads from the alt to the battery having a loose connection. Tightened it up and fine since.
paulsstuff is offline  
post #3 of 11 (permalink) Old Sep 22nd, 12, 10:05 PM Thread Starter
 
Join Date: Oct 2003
Location: Idaho
Posts: 16
Re: Why is my Alt. light on

I just checked that and it seems to be ok
srtmember is offline  
 
post #4 of 11 (permalink) Old Sep 22nd, 12, 11:05 PM
Retired
Jim
 
click's Avatar
 
Join Date: Jun 2001
Location: Central Minnesota
Posts: 15,986
Re: Why is my Alt. light on

check connections at the Voltag Regulator and if you have not yet replaced it, replace it with electronic version Wells VR715 about $10 at most parts stores. Clean grounds and use star washers to make sure grounds are tight. Grounds cause most issues we see here in Elec. section .

Click..is Jim..former owner of a 69RS-LM1 350/255 - 700r
"There will come a time when you believe everything is finished,
That will be the beginning." Louis L'Amour
click is offline  
post #5 of 11 (permalink) Old Sep 22nd, 12, 11:47 PM
Senior Tech
Kev
 
Join Date: Dec 2007
Location: North Texas
Posts: 624
Re: Why is my Alt. light on

Measure the voltage on the battery when the engine is running and not. 12.6 not running; ~14.5 running.
67sc is offline  
post #6 of 11 (permalink) Old Sep 24th, 12, 09:07 PM Thread Starter
 
Join Date: Oct 2003
Location: Idaho
Posts: 16
Re: Why is my Alt. light on

Checked all my grounds, there ok. checked wire conections to the alt. it's ok battery not running is 12.6 and 14.5 running. I'm sure that something is grounded but where?
srtmember is offline  
post #7 of 11 (permalink) Old Sep 24th, 12, 09:57 PM
Senior Tech
Shane
 
Join Date: Oct 2011
Location: Utah
Posts: 129
Re: Why is my Alt. light on

Mine did the same, go with the VR715 advice, took care of my idiot light issue. Except here it was about $25
stea is offline  
post #8 of 11 (permalink) Old Sep 25th, 12, 04:08 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,880
Garage
Re: Why is my Alt. light on

Reads like the feild relay in the VR is not energizing to turn off the GEN light.
White wire from the alt supplies relay power to close the relay.

If this is the case, alt has power on white wire, then VR is bad.
As suggested by Jim, Shane, and myself, get a Wells unit and plug and play.
RockAuto, a sponsor here, sells them reasonably.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is online now  
post #9 of 11 (permalink) Old Oct 1st, 12, 03:58 PM Thread Starter
 
Join Date: Oct 2003
Location: Idaho
Posts: 16
Re: Why is my Alt. light on

I finally figured it out. The Diode Trio in the alt. was bad. Replaced the Trio and it works great. Thanks for all your help.
srtmember is offline  
post #10 of 11 (permalink) Old Oct 1st, 12, 06:13 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,880
Garage
Re: Why is my Alt. light on

Glad you found the problem. Internal regulated alternator.
Should have asked what alternator model you were running.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is online now  
post #11 of 11 (permalink) Old Oct 1st, 12, 07:44 PM
Senior Tech
Shane
 
Join Date: Oct 2011
Location: Utah
Posts: 129
Re: Why is my Alt. light on

LOL yes, we should have asked.
stea is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome