67 turn signals - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 22 (permalink) Old Feb 22nd, 13, 04:05 PM Thread Starter
Gold Lifetime Member
 
Join Date: Jul 2002
Location: CHES. VA
Posts: 69
67 turn signals

I'm having problems with the front turn signals. Need some help please.I have a 67 camaro rs. All new wiring from AAW. All new parts throughout. I have running lights front and back. I have both rear turn signals. I have driver side front turn signal. But I donot have a pass. side front turn signal. Tried different bulbs, bought another new turn signal/light housing, and still nothing. Any ideas????? Been on this for weeks now.
RSSS69 is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old Feb 22nd, 13, 04:09 PM
Tech Team
Tony
 
Join Date: Feb 2013
Location: North Carolina
Posts: 42
Re: 67turn signals

Did you check to see if you even getting power to the socket?
Messenjah is offline  
post #3 of 22 (permalink) Old Feb 22nd, 13, 04:24 PM Thread Starter
Gold Lifetime Member
 
Join Date: Jul 2002
Location: CHES. VA
Posts: 69
Re: 67turn signals

Yea I have pass side running light. But when I turn on blinker or flashers nothing.
RSSS69 is offline  
 
post #4 of 22 (permalink) Old Feb 22nd, 13, 04:24 PM
Senior Tech
J.R.
 
Join Date: Feb 2008
Location: Charleston, WV
Posts: 193
Garage
Re: 67turn signals

Check your ground wire connection first.
adjudimo is offline  
post #5 of 22 (permalink) Old Feb 22nd, 13, 04:28 PM
Senior Tech
J.R.
 
Join Date: Feb 2008
Location: Charleston, WV
Posts: 193
Garage
Re: 67turn signals

Sorry, your last post showed up after I mentioned the ground. Must have a ground already if the light comes on. Still thinking what to mention for you to look at. I did a AAW classic update throughout my 67 and so far everything is working.
adjudimo is offline  
post #6 of 22 (permalink) Old Feb 22nd, 13, 04:29 PM Thread Starter
Gold Lifetime Member
 
Join Date: Jul 2002
Location: CHES. VA
Posts: 69
Re: 67turn signals

Done that went to all gnds and took grinder to get to bare metal, so I know their tight and touching bare metal and paint is not affecting it.
RSSS69 is offline  
post #7 of 22 (permalink) Old Feb 22nd, 13, 04:40 PM
Senior Tech
J.R.
 
Join Date: Feb 2008
Location: Charleston, WV
Posts: 193
Garage
Re: 67turn signals

I'm sorta wondering if it might be a bad or loose connection at either the turn signal switch in column or possibly one loose in the main harness connector just under the dash that connect to the steering column. I am not sure if it is possible for the round blinker in the fuse block could cause this problem and I was also wondering if your dash indicator bulb for the affected light is lighting up when you turn your signal on. Sometimes on some cars, if the actual blinker light burns out in the dash, the outside light is affected.
adjudimo is offline  
post #8 of 22 (permalink) Old Feb 22nd, 13, 05:10 PM Thread Starter
Gold Lifetime Member
 
Join Date: Jul 2002
Location: CHES. VA
Posts: 69
Re: 67turn signals

Dash indicator works. both left and right. I thought maybe it was in column. steering column new . Also I would think if it was in column then I would not have rear blinker, which I do have. even though I have other blinkers could the flasher be bad
RSSS69 is offline  
post #9 of 22 (permalink) Old Feb 22nd, 13, 06:37 PM
Gold Lifetime Member
Scott
 
Join Date: Oct 2010
Location: Pennsylvania
Posts: 413
Re: 67turn signals

I had problems with replacement bulbs. The lead bumps on the end of the bulb did not contact the socket (too flat). Added some solder and that fixed that.
stouchton is offline  
post #10 of 22 (permalink) Old Feb 22nd, 13, 06:40 PM
Gold Lifetime Member
jared
 
Join Date: Sep 2008
Location: Fairfax, Mo
Posts: 1,097
Re: 67turn signals

I had a prob with a new aaw wiring kit on my 67 rs/ss. Everything worked great but the high beams, traced wires and traced wires , only to find that at the aaw factory they didn't strip the insulation off the wire when they crimped it in the fitting. This was on the drivers side ,so it had a double wire also running to the pass side light. Took me 2 days to find it. Even called them to vent a little.
jcfcamaro is offline  
post #11 of 22 (permalink) Old Feb 23rd, 13, 06:28 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,853
Garage
Re: 67turn signals

Check power at the light socket with blinker on.
You have rear blinker and indicator all from within the pass side of firewall.
Indicator is wired to front bulb at the firewall connector.
Flasher is fine, it flashes. Flasher on fuse panel is for emergency lights.
T/signal flasher is behind the dash just above the gas pedal. You might want to replace it with a heavy duty unit, 552.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
post #12 of 22 (permalink) Old Feb 23rd, 13, 08:04 AM Thread Starter
Gold Lifetime Member
 
Join Date: Jul 2002
Location: CHES. VA
Posts: 69
Re: 67 turn signals

Replaced flasher with heavy duty type 552, still no flasher. I've changed bulbs, I've added solder to the ends of bulbs just to try it. Still nothing. As you mentioned about the head lights, thats my next issue. I have high beam but no low beams. changed bulbs with new ones, change new dimmer switch with another new one. I'll check the wires at the connectors as you mentioned next. But keepcoming up empty. My head light doors will not openor close either. All new parts from ricks. realys etc... I've gone throught the trouble shooting guide and so far everything checks out. If the diode is bad will that stop the doors from opening and closing, and would it also have anything to do with the low beams.
RSSS69 is offline  
post #13 of 22 (permalink) Old Feb 23rd, 13, 03:22 PM
Gold Lifetime Member
jared
 
Join Date: Sep 2008
Location: Fairfax, Mo
Posts: 1,097
Re: 67 turn signals

The diode will keep them from closing, I think.You must have your key on also to get them to close. My diode was bad also,they would open but would never close,until I started messing with the diode harness and heard the light doors jump a little,then I found that by pulling or pushing on the diode I could make it work or not work. I found on here a radio shack number to replace it for a couple of bucks and there are 3 in a bag,you just have to solder it in.But you need to test it before you replace it.It should have juice going out ,but not let it back the other way when the key is off,double ckeck all this , I'm not sure
jcfcamaro is offline  
post #14 of 22 (permalink) Old Feb 23rd, 13, 04:52 PM
Senior Tech
Nick
 
Join Date: Nov 2001
Location: BARRIE ONT CANADA
Posts: 760
Re: 67 turn signals

do you have a 1157 socket and bulb in there (thats with two contacts?)

67 rs/ss 350 original eng,700r4, a/c, tilt, deluxe int,strato bench,Ca.emission,front disk,am/fm,floor clock,17" W/V Ralleys,Toyo T1S 255/40/17, 245/40/17
MRCOOL_RSSS350 is offline  
post #15 of 22 (permalink) Old Feb 23rd, 13, 05:59 PM Thread Starter
Gold Lifetime Member
 
Join Date: Jul 2002
Location: CHES. VA
Posts: 69
Re: 67 turn signals

yep tried several bulbs, evan added some solder to one bulb, thinking it was not making contact. I've been all over this thing for weeks. Like I said in earlier post evan bought a new light houisng thinking maybe there was something wrong with the first new housing.
RSSS69 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome