1967 Camaro brake lights not working - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Mar 10th, 13, 01:41 PM Thread Starter
Wesley
 
Join Date: Dec 2012
Location: Texas
Posts: 14
1967 Camaro brake lights not working

My 67 camaro brake lights are not working. My tail lights, blinkers, and flashers work except for the brake lights. The bulbs are good and the brake switch works, but there is not 12 volts to either side of the switch. All of the fuses are good. What else should I check? I'm planning on trying a new blinker switch, I've read that it could be bad.

67 SS 454 4 speed
Wpeschel is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Mar 10th, 13, 02:36 PM
Gold Lifetime Member
jared
 
Join Date: Sep 2008
Location: Fairfax, Mo
Posts: 1,097
Re: 1967 Camaro brake lights not working

you do have the 1157 bulbs right ?
jcfcamaro is offline  
post #3 of 6 (permalink) Old Mar 10th, 13, 05:38 PM Thread Starter
Wesley
 
Join Date: Dec 2012
Location: Texas
Posts: 14
Re: 1967 Camaro brake lights not working

Yes. They used to work before the car sat in stirage for several years.

67 SS 454 4 speed
Wpeschel is offline  
 
post #4 of 6 (permalink) Old Mar 10th, 13, 06:01 PM
Gold Lifetime Member
jared
 
Join Date: Sep 2008
Location: Fairfax, Mo
Posts: 1,097
Re: 1967 Camaro brake lights not working

Not sure which brake light switch wire is the hot coming in, but i'd trace them. I do know that behind the drivers kick panel is the plug and harness that runs all the wires back to the tail lights,so if one of the brake light switch wires runs over to the side of the kick panel trace the other switch wire to find the hot side>. you might make sure your column wiring plug is tight together .

Last edited by jcfcamaro; Mar 10th, 13 at 06:06 PM. Reason: column
jcfcamaro is offline  
post #5 of 6 (permalink) Old Mar 10th, 13, 06:36 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,853
Garage
Re: 1967 Camaro brake lights not working

Stop lights get their power from fuse panel.
Then to brake light switch, then to column through turn signal switch.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
post #6 of 6 (permalink) Old Mar 12th, 13, 08:44 PM Thread Starter
Wesley
 
Join Date: Dec 2012
Location: Texas
Posts: 14
Re: 1967 Camaro brake lights not working

Ok after doing some more testing I have found out that my brake switch is not working correctly, sometimes it works, and sometimes it does not. After unplugging and plugging back in the big plug to the turn signal switch, I now have power to the orange wire at the brake pedal switch. A bypassed the brake switch and the brake lights now work, but they will not work while a turn signal is on. What else should I look at? I have a new turn signal switch and brake switch I will install tomorrow.

67 SS 454 4 speed
Wpeschel is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome