Turn signal help please - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Mar 31st, 13, 06:26 PM Thread Starter
Tommy
 
Join Date: Mar 2011
Location: United States
Posts: 16
Turn signal help please

Hey guys needing some help. All of my lights work properly except for the right front turn signal.

I can take a power probe and inject 12 volts into the harness that goes down to the light (brown / blue wires) and I can force the parking lamp and turn signal lamp illuminate like they should. So they tells me bulb connections and grounds are good to that point.

But when I get to the fire wall I am not sure we're the next point should be to inject the 12 volts again to see if I can find where it's open at.

I assume with the right rear working the turn signal switch at the column is working properly.

So I guess question is does anyone have a good test point inside the car between the firewall and the column?

69 Z28 X77
zfuzz is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Mar 31st, 13, 06:42 PM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: Turn signal help please

could be a few things such as the turn signal switch, hazard light switch, brake light switch as they are all inter connected. Does the light light as parking? Does the light flash with hazards and if yes, does it stop flashing and stay lighted when you hit the brakes?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
post #3 of 6 (permalink) Old Mar 31st, 13, 06:45 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,864
Garage
Re: Turn signal help please

You should be able get to the same color of wires on the steering column connector.
Turn signal indicator in the inst cluster is tied into firewall connector for rt front.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden Ö enjoy your next chapter.
Everett#2390 is offline  
 
post #4 of 6 (permalink) Old Mar 31st, 13, 08:22 PM
Gold Lifetime Member
George
 
Gbauer's Avatar
 
Join Date: Nov 2012
Location: Frederick, MD
Posts: 8,047
Re: Turn signal help please

Try replacing the light bulb in the dash.

Sold:
1968 Base hardtop 250 with a P̶G̶ built 2004r
Offy intake
Holley 390 CFM carb
Langdon split header to a 2.5" exhaust
Mild cam
Custom interior
Gbauer is offline  
post #5 of 6 (permalink) Old Apr 1st, 13, 05:21 PM Thread Starter
Tommy
 
Join Date: Mar 2011
Location: United States
Posts: 16
Re: Turn signal help please

Thanks guys for the tips, I found the dark blue wire on the column and verified the turn signal switch was working. So from there started working my way back toward the firewall.

Found that I have switch connectivity to the blue wire right before it goes into the fuse block but nothing on the engine bay side of the fuse block connector.

So before I take the block apart is there a trick to getting it back together? The bolt on the engine bay side looks like its going to be a bear to get back in due to the power brake booster.

69 Z28 X77
zfuzz is offline  
post #6 of 6 (permalink) Old Apr 5th, 13, 05:25 AM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: Turn signal help please

Yeah it is a rough place but you can do it with everything in place. I have seen guys with thicker builds take either the booster or the fender off. I would try to avoid that.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome