How many Amps - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jun 26th, 13, 05:28 PM Thread Starter
Senior Tech
 
Join Date: Jul 2007
Location: Oakville Ontario Canada
Posts: 176
How many Amps

How man amps and volt does a blower motor pull ?
meusebi is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jun 26th, 13, 07:18 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,879
Garage
Re: How many Amps

Fourteen volts, about 6-7 amps.
Twelve volts, about 7-8 amps.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
post #3 of 5 (permalink) Old Jun 27th, 13, 05:10 AM Thread Starter
Senior Tech
 
Join Date: Jul 2007
Location: Oakville Ontario Canada
Posts: 176
Re: How many Amps

Thank you mine is only pulling 2 amps so a least it is not pulling to much.
meusebi is offline  
 
post #4 of 5 (permalink) Old Jun 27th, 13, 11:53 AM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: How many Amps

Startup current will always be higher, though I couldn't tell you what a normal number might be. Once the motor spins up it should run at a lower amperage. If the amperage is too low, be on the lookout for bad connections. Bad connections add resistance, reduce the current and dissipate your current as heat that only serves to melt connections and burn things.

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
post #5 of 5 (permalink) Old Jun 29th, 13, 07:13 AM Thread Starter
Senior Tech
 
Join Date: Jul 2007
Location: Oakville Ontario Canada
Posts: 176
Re: How many Amps

I was just testing it connected to the battery with a piece of wire it was out of the car it more than likely I did not have a good connection. I am completely rewiring the car and the plugs to heater were burnt out so I wanted to test the blower motor. I am going to change the switch on the controls and change on the harness and check again.
meusebi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome