68 dash bulb socket problem - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Aug 22nd, 14, 08:22 AM Thread Starter
Jim
 
Join Date: May 2013
Location: Florida
Posts: 3
68 dash bulb socket problem

Is it possible to have bad dash bulb sockets. My speedo cluster has been sitting for out of the car for 14 years. Everything was working when it was disassembled. I installed the speedo and was checking to make sure everything was working. Read the posts about grounding and I'm sure everything will work once I add the additional grounding wire. Here's the problem. I pulled each of the sockets out and bench tested them, one side of the clip to hot and the other side to direct ground using the battery and alligator clips. All new bulbs. Only two worked. Took the known good bulb and put in another socket and it did not work. It's not rocket science but is it possible to have the sockets just not work anymore? I did all the checks by prying up the tabs, cleaning the contacts, etc. But 6 out of the 8 bad??? Any help would be appreciated.
bowtie5768 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Aug 22nd, 14, 08:26 AM
Gold Lifetime Member
Jason
 
blue89bird's Avatar
 
Join Date: Sep 2005
Location: NJ
Posts: 2,043
Re: 68 dash bulb socket problem

my guess is its not the sockets and is the bulbs. I had to bend the wires a bit on the bottom of almost all of the bulbs to make sure they made good contact.

Jason
2009 CTS-V - 1968 Camaro 327/M20 Sequoia Green
blue89bird is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome