New Delco Battery not holding charge - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 20 (permalink) Old Nov 2nd, 14, 03:34 PM Thread Starter
Senior Tech
Brian
 
Join Date: Nov 2000
Location: Ontario, Canada
Posts: 1,290
New Delco Battery not holding charge

I recently purchased a GM Delco battery for my 68. I have not driven it a lot and it sat for about a month. I went to start it and after 3 cranks it went dead. I charged it and it started right up. The next day same thing. I am getting 14 volts at the battery when running and l I was wondering if I have a bad battery.
I charged it to 13.2 then it slowly lowered to 12.4. volts with battery disconnected.
Not sure what to do.

I have owned 3 69 Z/28s: Garnet Red 30,000 mi unrestored.
Glacier Blue, documented Canadian Z
Rallye Green purchased new in 1969
1968 Camaro Coupe L30 275 horse. ]
Stewie is offline  
Sponsored Links
Advertisement
 
post #2 of 20 (permalink) Old Nov 2nd, 14, 04:11 PM
Senior Tech
Garth
 
Join Date: Oct 2012
Location: PA
Posts: 1,171
Garage
Re: New Delco Battery not holding charge

I would say it's bad.

1969 Camaro SS 350 LeMans Blue
2015 Z/28 - Red
2 x 1967 R/Tís
1977 Power Wagon
1978 Liíl Red Express
69L48Z27 is offline  
post #3 of 20 (permalink) Old Nov 2nd, 14, 04:32 PM
Senior Tech
Al
 
Join Date: Nov 2002
Location: Vancouver, USA
Posts: 10,512
Re: New Delco Battery not holding charge

Check to see if there is a draw on the batt - with everything off and doors closed disconnect the neg cable and put a test light between the cable end and the neg batt terminal. If the test light illuminates something is drawing current. Pull fuses one at a time, closing door each time, to determine which circuit is at fault. If nothing found, disconnect wires to the alternator and do the test.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BPOS is offline  
 
post #4 of 20 (permalink) Old Nov 2nd, 14, 08:05 PM
Senior Tech
Don
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Re: New Delco Battery not holding charge

Would your battery happen to be a Delco "Professional"?

If so I've seen them go bad very quickly.

Don ~ TC Member #15 ~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Don't mess with Texas!
ZZ_430 is offline  
post #5 of 20 (permalink) Old Nov 3rd, 14, 04:17 AM Thread Starter
Senior Tech
Brian
 
Join Date: Nov 2000
Location: Ontario, Canada
Posts: 1,290
Re: New Delco Battery not holding charge

Yes it is. What model should I replace it with?

I have owned 3 69 Z/28s: Garnet Red 30,000 mi unrestored.
Glacier Blue, documented Canadian Z
Rallye Green purchased new in 1969
1968 Camaro Coupe L30 275 horse. ]
Stewie is offline  
post #6 of 20 (permalink) Old Nov 3rd, 14, 04:18 AM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,511
Garage
Re: New Delco Battery not holding charge

I've had no issues with AutoZone's Duralast line of batteries for side posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
post #7 of 20 (permalink) Old Nov 3rd, 14, 05:09 AM
Senior Tech
Steiner
 
Join Date: Mar 2009
Location: Lyman, SC
Posts: 8,348
Re: New Delco Battery not holding charge

Just had a Duralast Gold lose a cell at a year old. Man, it's just hit or miss sometimes. They swapped it out and basically I lost about $30 because the price had dropped. Haven't had a problem yet with an Everstart Max from Wal-Mart though.

'69 Camaro
Dart 400-AFR 195-224/224 HR-Powerjection III TB with F.A.S.T. Sportsman XFI
TKO 600-Moser 3.42-Detroit Truetrac
500hp/538lbft

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'69 Camaro Beater-SFT 327-M20-Moser 4.10-sold
'02 Z/28 vert-stock-sold and totaled
Steiner is offline  
post #8 of 20 (permalink) Old Nov 3rd, 14, 05:42 AM Thread Starter
Senior Tech
Brian
 
Join Date: Nov 2000
Location: Ontario, Canada
Posts: 1,290
Re: New Delco Battery not holding charge

Cost is not a factor, I just wanted something that worked. I like to have Delco in the car but I don"t see it happening. I am going to return it and see how the next one goes. I will be putting the car to bed for the winter so the battery comes inside. I had it charged last night and dissconnected. This morning it only took 5 cranks then it died again. 12.4 volts.

I have owned 3 69 Z/28s: Garnet Red 30,000 mi unrestored.
Glacier Blue, documented Canadian Z
Rallye Green purchased new in 1969
1968 Camaro Coupe L30 275 horse. ]
Stewie is offline  
post #9 of 20 (permalink) Old Nov 3rd, 14, 07:59 AM
Senior Tech
Don
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Re: New Delco Battery not holding charge

Quote:
Originally Posted by Stewie View Post
Yes it is. What model should I replace it with?
Well, I had a Sears Die-Hard Gold last for more than 7 years.

I've also had good luck with the Walmart batteries believe it or not.

The Duralast battery is ok, but I've seen them die prematurely.

You really can't beat the Optima though, and they are all I use now.

Don ~ TC Member #15 ~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Don't mess with Texas!
ZZ_430 is offline  
post #10 of 20 (permalink) Old Nov 3rd, 14, 08:39 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 32,014
Garage
Re: New Delco Battery not holding charge

If setting up for the winter, you might hook up a modern day charger in the 2 AMP position just to keep the new battery charged.

A battery has to be used and charged to keep its young looks.
Wally Mart Everlast was good when I was using them and Interstate is the brand I use now.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden Ö enjoy your next chapter.
Everett#2390 is offline  
post #11 of 20 (permalink) Old Nov 3rd, 14, 08:55 AM
Senior Tech
Paul B
 
Join Date: Jul 2012
Location: Ontario
Posts: 273
Re: New Delco Battery not holding charge

Quote:
Originally Posted by Stewie View Post
I recently purchased a GM Delco battery for my 68. I have not driven it a lot and it sat for about a month. I went to start it and after 3 cranks it went dead. I charged it and it started right up. The next day same thing. I am getting 14 volts at the battery when running and l I was wondering if I have a bad battery.
I charged it to 13.2 then it slowly lowered to 12.4. volts with battery disconnected.
Not sure what to do.
Delco Proffesional batteries now have a straight over the counter exchange. If you purchased it recently, it should be here's my old one, here's your new one deal. That's what we do at the GM dealer I work at.
paulsstuff is offline  
post #12 of 20 (permalink) Old Nov 8th, 14, 04:53 AM Thread Starter
Senior Tech
Brian
 
Join Date: Nov 2000
Location: Ontario, Canada
Posts: 1,290
Re: New Delco Battery not holding charge

Quote:
Originally Posted by paulsstuff View Post
Delco Proffesional batteries now have a straight over the counter exchange. If you purchased it recently, it should be here's my old one, here's your new one deal. That's what we do at the GM dealer I work at.
Yes I took it in to Brian Cullen Motors and they did as you said. Originally the girl said they had to load test it, but then called later, and said they would replace it, I asked what it tested at and she said they didn't test it but would replace it. They asked for the VIN number and I told them it was a 1968 Camaro, but they used my VIN anyway to process the return. Now I hope the new one will be better. I wonder if my Vin is still on their computers, I do have the Zapora report for it.

I have owned 3 69 Z/28s: Garnet Red 30,000 mi unrestored.
Glacier Blue, documented Canadian Z
Rallye Green purchased new in 1969
1968 Camaro Coupe L30 275 horse. ]
Stewie is offline  
post #13 of 20 (permalink) Old Nov 8th, 14, 05:17 AM
Senior Tech
Mark
 
Join Date: Sep 1998
Location: Ontario, Canada
Posts: 2,009
Garage
Re: New Delco Battery not holding charge

I'd return it and GM Pro Rates the batteries.

Mark 70 Z28 M22 3.73 Z21 Z87 - Lunati 20120121 Roller Cam

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
COPO is offline  
post #14 of 20 (permalink) Old Nov 8th, 14, 05:47 AM Thread Starter
Senior Tech
Brian
 
Join Date: Nov 2000
Location: Ontario, Canada
Posts: 1,290
Re: New Delco Battery not holding charge

Quote:
Originally Posted by COPO View Post
I'd return it and GM Pro Rates the batteries.
I did return it and it has a full replacement warranty. I only bought it in late July.

I have owned 3 69 Z/28s: Garnet Red 30,000 mi unrestored.
Glacier Blue, documented Canadian Z
Rallye Green purchased new in 1969
1968 Camaro Coupe L30 275 horse. ]
Stewie is offline  
post #15 of 20 (permalink) Old Nov 9th, 14, 07:40 AM
Senior Tech
Anne
 
Join Date: Jan 2013
Location: Eddyville KY
Posts: 1,470
Re: New Delco Battery not holding charge

Quote:
Originally Posted by Everett#2390 View Post
If setting up for the winter, you might hook up a modern day charger in the 2 AMP position just to keep the new battery charged.

A battery has to be used and charged to keep its young looks.
Wally Mart Everlast was good when I was using them and Interstate is the brand I use now.
I saw this battery charger on Jay Leno's Garage. Looks good :


Government's first duty is to protect the people, not run their lives.
Ronald Reagan

Last edited by 69-Pace; Nov 9th, 14 at 04:21 PM.
Lawrence454 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome