Won't Quit Running? - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old Jan 1st, 15, 07:02 AM Thread Starter
Senior Tech
Bruce
 
Join Date: Mar 2008
Location: Waxhaw, NC
Posts: 2,604
Won't Quit Running?

Turn the key to the off position on my 69 and the engine keeps running. I am thinking to start with the ignition switch. . . .any other thoughts?
The Camaro Guy is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old Jan 1st, 15, 07:19 AM
Senior Tech
 
Join Date: Dec 2001
Location: Fairfield, CA
Posts: 6,246
Re: Won't Quit Running?

Have you made any recent changes that would cause this problem?

"For those that will fight for it...FREEDOM ...has a flavor the protected shall never know."
Semper Fi! L/Cpl Edwin L. "Tim" Craft, B Co 3rd AT's, Khe Sanh Combat Base, February, 1968
onovakind67 is offline  
post #3 of 7 (permalink) Old Jan 1st, 15, 07:27 AM
Senior Tech
Karl
 
VetteFreak's Avatar
 
Join Date: Jul 2013
Location: New Bloomfield, PA
Posts: 922
Garage
Re: Won't Quit Running?

Are you running an internally regulated alternator? If so, have it checked. I've seen faulty diodes cause this problem.

Karl / VetteFreak
69 Camaro RS 350/350TH...Burgundy...711-Black Int/Houndstooth Seats
2007 Corvette Conv. LS-2/A6...Monterey Red/Black Top & Int
VetteFreak is offline  
 
post #4 of 7 (permalink) Old Jan 1st, 15, 07:51 AM
Gold Lifetime Member
steve
 
Join Date: Apr 2009
Location: central nd
Posts: 238
Re: Won't Quit Running?

are you running MSD? If yes you may need to add a diode
grampstoyz is offline  
post #5 of 7 (permalink) Old Jan 1st, 15, 08:39 AM Thread Starter
Senior Tech
Bruce
 
Join Date: Mar 2008
Location: Waxhaw, NC
Posts: 2,604
Re: Won't Quit Running?

No recent changes. It has an internally regulated alternator that has been on the car for several years. No MSD.
The Camaro Guy is offline  
post #6 of 7 (permalink) Old Jan 1st, 15, 08:50 AM
Senior Tech
Karl
 
VetteFreak's Avatar
 
Join Date: Jul 2013
Location: New Bloomfield, PA
Posts: 922
Garage
Re: Won't Quit Running?

Quote:
Originally Posted by The Camaro Guy View Post
No recent changes. It has an internally regulated alternator that has been on the car for several years. No MSD.
Take your IR alternator to an auto parts and have it checked

Karl / VetteFreak
69 Camaro RS 350/350TH...Burgundy...711-Black Int/Houndstooth Seats
2007 Corvette Conv. LS-2/A6...Monterey Red/Black Top & Int
VetteFreak is offline  
post #7 of 7 (permalink) Old Jan 1st, 15, 09:32 AM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: Won't Quit Running?

Nothing like a New Years Day bug hunt. Try this trouble shooter from the archives:
https://www.camaros.net/forums/showth...ng#post1464138


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome