Wires on front end of 67 RS - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old Mar 8th, 15, 11:18 PM Thread Starter
Senior Tech
A
 
Join Date: Aug 2011
Location: CA
Posts: 189
Wires on front end of 67 RS

Where do these wires go? This is on a 67 RS. They are labeled top and bottom and come from the headlamp plug. Are they for the limit switches on the headlamp doors?




1967 RS In Progress
327 with a 4 speed
XedLos is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old Mar 9th, 15, 12:56 AM
Gold Lifetime Member
Allen
 
Join Date: Oct 2005
Location: Deer Park, Tx
Posts: 60
Re: Wires on front end of 67 RS

Yes.

69 X-11 RS Conv. Deluxe Int, PW, PT.
69 X-11, Column shift, 350, 12 bolt 4:11, Yenko Clone
68 SS clone, tach, console gauges, 355 with 700R4
67 RS/SS clone, BB, Auto, 12 bolt 4:11
racin67cam is offline  
post #3 of 11 (permalink) Old Mar 9th, 15, 03:37 AM
Gold Lifetime Member
jared
 
Join Date: Sep 2008
Location: Fairfax, Mo
Posts: 1,097
Re: Wires on front end of 67 RS

Yes
jcfcamaro is offline  
 
post #4 of 11 (permalink) Old Mar 9th, 15, 04:21 PM
Gold Lifetime Member
Rick
 
Join Date: Dec 2012
Location: collingwood canada
Posts: 444
Re: Wires on front end of 67 RS

Here is some help on my facebook page

https://www.facebook.com/media/set/?...4909802&type=3
Ric67 is offline  
post #5 of 11 (permalink) Old Mar 9th, 15, 04:25 PM
Gold Lifetime Member
Roger
 
rogerh's Avatar
 
Join Date: Oct 2004
Location: Quincy, IL
Posts: 19,001
Re: Wires on front end of 67 RS

There should be eight connectors all together.
Four connectors for switches on the radiator supports and four for the switches inside the headlight assembly. This is a pic of the ones on the radiator support.

Roger
[/URL]

[/URL]

1967 Camaro SS/RS 350/295HP Coupe. First and only owner.
rogerh is online now  
post #6 of 11 (permalink) Old Mar 10th, 15, 12:34 PM Thread Starter
Senior Tech
A
 
Join Date: Aug 2011
Location: CA
Posts: 189
Re: Wires on front end of 67 RS

Oh thanks! I was missing the limit switches that mount to the headlight bracket. The ones that that are used when the headlight doors are open.

Either way my headlights or doors are not working. The only lights that work on the front are the turn signals. Anyone have any tips on what to check first? I replaced the motors with new ones from classic industries.

1967 RS In Progress
327 with a 4 speed
XedLos is offline  
post #7 of 11 (permalink) Old Mar 10th, 15, 12:48 PM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: Wires on front end of 67 RS

Quote:
Originally Posted by Ric67 View Post
Here is some help on my facebook page

https://www.facebook.com/media/set/?...4909802&type=3
Nice page Rick.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
post #8 of 11 (permalink) Old Mar 10th, 15, 02:28 PM
Gold Lifetime Member
Rick
 
Join Date: Dec 2012
Location: collingwood canada
Posts: 444
Re: Wires on front end of 67 RS

You are going to have to order at least 4 switches (forget where I got mine) all the black ground wires face down. Get some star washers for the ground wires so they bite into the metal. Take the neg battery cable off. Check to make sure the three relays under the drivers fender are hooked up along with the circuit breaker. There is also a diode under the dash. All the descriptions are on my facebook page. when all hooked up properly attach the neg battery cable (leave loose) **** should start to happen !!!! if motors keep running pull neg cable and adjust or shim switches until you can hear switches click then try putting cable back on battery. If nothing works try pulling the headlights and check to make sure their grounds are solid. Nothing works unless all switches and headlights are grounded. Took me about nine hours of playing to get them working properly and trouble free since !
Have fun and there is lots of help here.
Rick
Ric67 is offline  
post #9 of 11 (permalink) Old Mar 11th, 15, 09:38 PM Thread Starter
Senior Tech
A
 
Join Date: Aug 2011
Location: CA
Posts: 189
Re: Wires on front end of 67 RS

I installed all of my limit switches and got my headlights to turn on and off. My motors don't work yet so I'll be going through the trouble shooting suggestions.

Also my knob on the switch slips off when I pull it. Is it broken or is there a way to make it not slip off when pulling?


Quote:
Originally Posted by Ric67 View Post
Here is some help on my facebook page

https://www.facebook.com/media/set/?...4909802&type=3
I don't have Facebook :/

1967 RS In Progress
327 with a 4 speed
XedLos is offline  
post #10 of 11 (permalink) Old Mar 13th, 15, 09:09 PM
Gold Lifetime Member
Rick
 
Join Date: Dec 2012
Location: collingwood canada
Posts: 444
Re: Wires on front end of 67 RS

I would guess the motors are not plugged in. Also they could both be burned out. the wires are probably tucked in there somewhere !
Rick
Ric67 is offline  
post #11 of 11 (permalink) Old Mar 13th, 15, 09:11 PM
Gold Lifetime Member
Rick
 
Join Date: Dec 2012
Location: collingwood canada
Posts: 444
Re: Wires on front end of 67 RS

Are the relays under the drivers fender hooked up?
Ric67 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome