69 AC Blower motor - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Apr 17th, 15, 04:25 PM Thread Starter
Senior Tech
Alex
 
Join Date: Feb 2015
Location: Houston TX
Posts: 121
69 AC Blower motor

My blower works on low and on high speeds but does not work on med speed? What and where should I look and test? Pictures always help. Thanks Alex

1969 RS Camaro
1972 K5 Blazer
2010 Dodge Ram 2500 4X4
1969RSCAMARO is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Apr 17th, 15, 07:13 PM
Tech Team
 
Coppertop's Avatar
 
Join Date: Aug 1998
Posts: 46
Re: 69 AC Blower motor

The first thing to check is the resistor assembly. This is mounted on the evaporator "suitcase" under the hood. You'll see a number of multi colored wires with a plug going into it. Unplug the connector and inspect for corrosion or damage. Then remove the 2 hex head screws and pull out the resistor assembly. They are wire wound resistors that resemble springs once pulled out of the case. Many times these corrode or go open from age. The resistors drop the voltage for the blower speeds--every speed but high.
Coppertop is offline  
post #3 of 3 (permalink) Old Apr 19th, 15, 05:11 AM Thread Starter
Senior Tech
Alex
 
Join Date: Feb 2015
Location: Houston TX
Posts: 121
Re: 69 AC Blower motor

I took the resistor out cleaned the terminals up reinstalled and got it working.

1969 RS Camaro
1972 K5 Blazer
2010 Dodge Ram 2500 4X4
1969RSCAMARO is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome