Chronic Front TurnSignal Problems - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Jun 26th, 15, 01:13 PM Thread Starter
Phil
 
Join Date: Jun 2015
Location: Ocala, florida
Posts: 1
Chronic Front TurnSignal Problems

I have a 2000 Camaro and the front left turn signal went out as the holder of the bulb melted...I replaced it with an OEM socket and replaced the bulb...and it worked fine...the next day...its dead...Though I cleaned the holder of the rear signal light...its dead too.
When I put on the emergency blinkers....the left front works, the right front does not and the left rear does not. I the right front DOES work as a turn signal when I drive...this is driving me nuts.
Any specific ideas?
Ocala 3.8 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jun 28th, 15, 05:53 PM
Senior Tech
Karl
 
VetteFreak's Avatar
 
Join Date: Jul 2013
Location: New Bloomfield, PA
Posts: 922
Garage
Re: Chronic Front TurnSignal Problems

Quote:
Originally Posted by Ocala 3.8 View Post
I have a 2000 Camaro and the front left turn signal went out as the holder of the bulb melted...I replaced it with an OEM socket and replaced the bulb...and it worked fine...the next day...its dead...Though I cleaned the holder of the rear signal light...its dead too.
When I put on the emergency blinkers....the left front works, the right front does not and the left rear does not. I the right front DOES work as a turn signal when I drive...this is driving me nuts.
Any specific ideas?
I've seen something like this mentioned before. I believe the turn signals are controlled through the (DRL) driving lights module. You may need to get a schematic and trace voltage through the circuits to find the culprit. Do a search online for wiring schematics for your model.

Karl / VetteFreak
69 Camaro RS 350/350TH...Burgundy...711-Black Int/Houndstooth Seats
2007 Corvette Conv. LS-2/A6...Monterey Red/Black Top & Int
VetteFreak is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome