1969 RS Camaro Horn honks when door opens - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jul 5th, 15, 10:04 AM Thread Starter
Chris
 
Join Date: Jun 2012
Location: California
Posts: 14
1969 RS Camaro Horn honks when door opens

Hi,
1969 RS Camaro here.
I have owned my car for about 4 years,the horn has never worked as long as i have had the car. I have done the following things.
1) Replaced the steering wheel /horn buttons and face of the wheel when i first got the car, because the wheel was cracked.
2) I replaced the horn relay because the horns did not work.
3) I figured out the horns were the originals and they were burned out,so i bought new horns.
Now that I have horns that work, when i open the drivers side door the horn honks.The horn also works when i use the horn button.
The car also is supposed to have a key buzzer alert when the door is opened and the key is in the ignition. I cant hear the buzzer over the horn.
I know the wires on the horn relay are not reversed because they only go on one way with plugs that are unique to each connector.

***Do I have some sort of grounding problem with the pink and black key buzzer wire ???

***Is the pink and black key buzzer wire somehow attached to the black horn wire by mistake at the wheel ???

If anyone else has had this problem , can you please post the solution.

Thanks
motobro is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jul 5th, 15, 10:36 AM
Senior Tech
George
 
Join Date: Aug 2014
Location: LI,NY
Posts: 1,057
Re: 1969 RS Camaro Horn honks when door opens

I would suspect the horn relay as the problem. Aside from working the horn, it also controls the key buzzer funcion too. Seems like something is crossed or miswired up there. Can you try with the old relay?
carbuff67rs is offline  
post #3 of 5 (permalink) Old Jul 5th, 15, 11:06 AM
Senior Tech
Jim
 
Join Date: Dec 2002
Location: Saint Louis, Missouri
Posts: 1,123
Re: 1969 RS Camaro Horn honks when door opens

I just did a round with a reproduction horn relay/key buzzer for my 68 Chevy II and below is a link to the pictures and how I corrected the issue I had (The horn portion worked but the key buzzer section did not).

https://www.flickr.com/photos/121766...57653574631828

To track things down, disconnect the wires from the horn relay/key buzzer and confirm that the one wire connects a ground when the horn button is depressed and then that another wire only connects a ground when the key is in the ignition and the driver's door is open. If both wires are doing what they should, then it's probably a horn relay/key buzzer issue. If they do not test out correctly, then the issue is elsewhere and possibly on the column connector. For the test, you could use an ohm meter or probably a low wattage test light.

Once that is confirmed, maybe take a jumper wire from the horn connector wire in the loom at the horn relay and connect it to the horn activation terminal on the relay and see what happens. Then disconnect that and see how the relay works with just the buzzer activation wire connected.

Jim

1974 Spirit Of America Nova (being restored), 1973 Nova Custom, 1968 Chevy II (Garage Find 2012)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SOA-Nova is offline  
 
post #4 of 5 (permalink) Old Jul 5th, 15, 01:36 PM
Gold Lifetime Member
Fred
 
77thor's Avatar
 
Join Date: Jun 2005
Location: Milwaukee, WI USA
Posts: 2,158
Re: 1969 RS Camaro Horn honks when door opens

Sorry... I just thought that the symptoms were amusing

1969 Camaro SS, 350(NOM), M21, 12 Bolt Posi, 01B LOS Build
1977 Camaro, 350(LM1), M20, 10 Bolt Posi, Purchased New, (SOLD)
77thor is offline  
post #5 of 5 (permalink) Old Jul 5th, 15, 02:33 PM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: 1969 RS Camaro Horn honks when door opens

If the key is NOT in the ignition do you still get horns when you open the door?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome