67 Camaro RS Turn Signal Issue - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Sep 16th, 15, 06:05 PM Thread Starter
Gold Lifetime Member
Tom
 
Join Date: Sep 2014
Location: NJ
Posts: 256
Cool 67 Camaro RS Turn Signal Issue

Hey Guys, I was driving my car tonight and noticed my left turn signal was not flashing on the dash, it did however make the blinking sound. Got home and checked everything out. The left rear signals were working fine. The front park lamp housing was not. Replaced the bulb and had no luck. Then checked for voltage at the fuse link feeding the lamp housing, the purple and black wires had no voltage at all. I did check the ground at the lamp housing going to the body and it was tight. Any suggestions? Thanks, Tom

67 Camaro RS Convertible 327 4 speed
Original unrestored, documented 35k Numbers Matching
69 Camaro SS Coupe X55 350/300hp 4 speed
Fully Restored Numbers Matching
1969 Camaro Z28 Restored
351just is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Sep 17th, 15, 04:20 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,847
Garage
Re: 67 Camaro RS Turn Signal Issue

Dash indicator and front turn light are wired together at the firewall.
I assume parking lights work, so socket ground is good.
Only place power comes from is turn signal switch.
Check light blue at steering column as this is going out to light.
Might jiggle handle - pull up.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is online now  
post #3 of 5 (permalink) Old Sep 22nd, 15, 09:06 PM Thread Starter
Gold Lifetime Member
Tom
 
Join Date: Sep 2014
Location: NJ
Posts: 256
Re: 67 Camaro RS Turn Signal Issue

Are you ready for this..... I took my 67 RS out tonight... The left front turn signal was working fine, including dash indicator light..... I guess something is loose.... I did order a new turn signal switch... I did not check the AIM yet, can I tighten the wires on the turn signal switch without taking everything apart (wheel puller) in the steering wheel? Thx Tom

67 Camaro RS Convertible 327 4 speed
Original unrestored, documented 35k Numbers Matching
69 Camaro SS Coupe X55 350/300hp 4 speed
Fully Restored Numbers Matching
1969 Camaro Z28 Restored
351just is offline  
 
post #4 of 5 (permalink) Old Sep 23rd, 15, 04:13 AM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: 67 Camaro RS Turn Signal Issue

The parking lamps have a junction in their harness runs as they travel from the valance to the main engine pod. I think it is just before the grommets and the junction is on the underside (at least on 69's) Check the left side for a loose connection at the junction - could explain no voltage. Maybe as it cooled the junction expanded to make a good connection again or you have a frayed or broken wire situation.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
post #5 of 5 (permalink) Old Sep 29th, 15, 07:49 PM Thread Starter
Gold Lifetime Member
Tom
 
Join Date: Sep 2014
Location: NJ
Posts: 256
Re: 67 Camaro RS Turn Signal Issue

Problem solved, harness on the firewall was loose... Check another one off the list. Thx Tom

67 Camaro RS Convertible 327 4 speed
Original unrestored, documented 35k Numbers Matching
69 Camaro SS Coupe X55 350/300hp 4 speed
Fully Restored Numbers Matching
1969 Camaro Z28 Restored
351just is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome