alternator & oil cluster lights - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Sep 22nd, 15, 12:05 PM Thread Starter
Tech Team
Steve
 
Join Date: Dec 2014
Location: Rhode Island
Posts: 45
alternator & oil cluster lights

My oil and alternator lights in dash cluster dont turn on when i turn key.I have a center console is this why they dont turn on?Pretty sure they work before cant remember.What to you guys think.
Stev15 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Sep 22nd, 15, 07:16 PM
Premium Member
Gordon
 
gordr's Avatar
 
Join Date: Jun 2009
Location: Kelowna, BC, Canada
Posts: 1,095
Re: alternator & oil cluster lights

Do you have gauges in the center console?

67 Plain Jane being assembled with 427, 4 spd Muncie, 12 bolt rear with Mosers, 4 wheel discs
gordr is offline  
post #3 of 4 (permalink) Old Sep 23rd, 15, 05:14 AM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: alternator & oil cluster lights

If you are still using original factory Alternator / Voltage Regulator set-up the GEN light should still self-test as the key turns through the on-start and run positions. Bulb maybe dead?

If you have factory gauges in the console the Oil light should have been converted to be the low FUEL light and the bezel changed to reflect its re-purpose.

It is possible your car was converted after birth to console gauges and the PO didn't bother to replace the bezel.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
 
post #4 of 4 (permalink) Old Sep 23rd, 15, 05:53 AM Thread Starter
Tech Team
Steve
 
Join Date: Dec 2014
Location: Rhode Island
Posts: 45
Re: alternator & oil cluster lights

It's has all factory gauges.I must have did something when i was under the hood.I'm sure it work before.I will have see what i screwed up.Thanks for help.
Stev15 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome