69 brake light - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Oct 15th, 15, 06:28 PM Thread Starter
robert
 
Join Date: Oct 2015
Location: kansas city
Posts: 1
69 brake light

All lights work except driver side brake light. Installed new flasher still no light. Any suggestions would be appreciated.
let r eat is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Oct 15th, 15, 06:29 PM
Moderator
John
 
Vega$69's Avatar
 
Join Date: Sep 2010
Location: Vegas NV/Wesley Chapel FL
Posts: 12,922
Garage
Re: 69 brake light

Quote:
Originally Posted by let r eat View Post
All lights work except driver side brake light. Installed new flasher still no light. Any suggestions would be appreciated.
Bulb or ground
Vega$69 is offline  
post #3 of 5 (permalink) Old Oct 15th, 15, 09:34 PM
Gold Lifetime Member
Larry
 
larryh56's Avatar
 
Join Date: Oct 2008
Location: Central Washington
Posts: 1,503
Re: 69 brake light

Check your ground with a meter

68 RS Coupe 355/350 TH, Detroit Speed, Hotchkis, Vintage Air, 8.5" 3.42 posi 10-bolt, MagnaFlow 2 1/2" exhaust, etc.

"The public cannot be too curious concerning the characters of public men."
Samuel Adams
larryh56 is offline  
 
post #4 of 5 (permalink) Old Oct 16th, 15, 09:57 AM
Gold Lifetime Member
Jeff
 
yellow69RS's Avatar
 
Join Date: Jul 2007
Location: Aurora, IL
Posts: 5,147
Send a message via Yahoo to yellow69RS
Re: 69 brake light

Does the turn signal work on that side? Be sure you have a brake light signal coming out of the T/S switch then trace you way back. It's possible the problem is the T/S switch.

Jeff
yellow69RS is offline  
post #5 of 5 (permalink) Old Oct 16th, 15, 10:41 PM
Gold Lifetime Member
Dave
 
Join Date: Jun 2006
Location: Vacaville CA
Posts: 1,368
Re: 69 brake light

I had a similar problem last year. Turned out to be a corroded contact in the bulb socket. I replaced the taillight harness. Very simple to change out.

Dave

Known to run with scissors....
__________
1969 Camaro Z/28 "clone", GMPP ZZ383, Autogear M22W, Moser 12bolt w/TruTrac 3:73.
Fred Mertz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome