67 Camaro 350 Temp idiotlight not working - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Dec 6th, 15, 02:44 PM Thread Starter
Tech Team
Dennis
 
Join Date: May 2006
Location: Williamston, SC
Posts: 38
Garage
67 Camaro 350 Temp idiotlight not working

I have replaced the dash temp bulb, tried grounding the wire, cannot get the bulb to light. The car is all stock and wiring looks to be in excellent condition. Any thoughts or suggestions?

68 Camaro RS/SS Convertible L34 396/350 Original/Stock

67 Camaro RS/SS Coupe 350/295 Original/Stock Hi Optioned

71 Challenger Convertible 318 Original/Stock

70 Cuda 440-6 Barrel Coupe Factory AC
Stingray_RSSS is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Dec 6th, 15, 05:21 PM
Senior Tech
George
 
Join Date: Aug 2014
Location: LI,NY
Posts: 1,057
Re: 67 Camaro 350 Temp idiotlight not working

Im assuming you had the key in the run position and then grounded the green wire under the hood?
carbuff67rs is offline  
post #3 of 4 (permalink) Old Dec 6th, 15, 07:22 PM
Senior Tech
George
 
Join Date: Aug 2014
Location: LI,NY
Posts: 1,057
Re: 67 Camaro 350 Temp idiotlight not working

Wait, this car is an ss350? Does it have factory gauges? If so, Im not sure it has a functioning temp light.
carbuff67rs is offline  
 
post #4 of 4 (permalink) Old Dec 6th, 15, 07:31 PM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: 67 Camaro 350 Temp idiotlight not working

Yes sting -

If it is a gauge sender you can test Ohm's when grounded.
A warning light switch will have only two states open and closed circuit for a bulb. You can also detect activity with the meter if the fuse is dead or the wiring interrupted in route through the bulkhead connection to the switch.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome