68 camaro blinker lights are mixed up - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old Dec 31st, 15, 03:01 PM Thread Starter
angelo
 
Join Date: Dec 2015
Location: Richmond texas
Posts: 5
68 camaro blinker lights are mixed up

My 68 camaro blinker lights are mixed up. When I turn indicator to right they all blink as if hazards are on unless my lights r on then nothing happens. When I turn indicator to the left they work fine with or without light on. And hazards don't work at all. What do I need to do? Thanks
yoyomo is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old Dec 31st, 15, 03:04 PM
Gold Lifetime Member
George
 
Gbauer's Avatar
 
Join Date: Nov 2012
Location: Frederick, MD
Posts: 8,047
Re: 68 camaro blinker lights are mixed up

You have a bad ground somewhere.

Sold:
1968 Base hardtop 250 with a P̶G̶ built 2004r
Offy intake
Holley 390 CFM carb
Langdon split header to a 2.5" exhaust
Mild cam
Custom interior
Gbauer is offline  
post #3 of 14 (permalink) Old Dec 31st, 15, 03:50 PM Thread Starter
angelo
 
Join Date: Dec 2015
Location: Richmond texas
Posts: 5
Re: 68 camaro blinker lights are mixed up

Where can I find info on finding this bad ground? Thanks
yoyomo is offline  
 
post #4 of 14 (permalink) Old Dec 31st, 15, 04:55 PM
Senior Tech
mike
 
Join Date: Jan 2011
Location: east coast
Posts: 2,288
Re: 68 camaro blinker lights are mixed up

Try taking one bulb out at a time and see if that changes anything. Also check out the flashers relay.
bigblockragtop is offline  
post #5 of 14 (permalink) Old Dec 31st, 15, 07:58 PM
Gold Lifetime Member
Matt
 
8ballracing's Avatar
 
Join Date: Oct 2003
Location: Jersey Shore
Posts: 1,091
Garage
Re: 68 camaro blinker lights are mixed up

X2 on grounds and relay.....also front turn signal housings can cause issues due to corrosion.... Remove the lens and try a direct ground wire to the socket the bulb goes in on the right front parking/turn signal light......

Do all the lights have the same brightness when flashes are on?

Happy New Year

8 Ball Racing
Member #120
1969 X77 9 E 69 302 M21 Wallace Chevrolet
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 RSSS rag top 7 E 69 350 turbo 350
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Triple Blue 10 D 68
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1968 Chevelle 03 A 68
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
8ballracing is offline  
post #6 of 14 (permalink) Old Dec 31st, 15, 10:29 PM Thread Starter
angelo
 
Join Date: Dec 2015
Location: Richmond texas
Posts: 5
Re: 68 camaro blinker lights are mixed up

All the same brightness.
yoyomo is offline  
post #7 of 14 (permalink) Old Dec 31st, 15, 11:10 PM
Gold Lifetime Member
Matt
 
8ballracing's Avatar
 
Join Date: Oct 2003
Location: Jersey Shore
Posts: 1,091
Garage
Re: 68 camaro blinker lights are mixed up

....same brightness grnds should be good. bulb type sounds correct all flashing.....

I would try replacing the turn signal relay or switch it with the Hazzard for a quick check. If it is not a relay....I would go to the turn signal assembly and look for a bad contact or broken part. Someone may have tried to repair a non canceiling issuse without sucess?

Hope this helps....

8 Ball Racing
Member #120
1969 X77 9 E 69 302 M21 Wallace Chevrolet
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 RSSS rag top 7 E 69 350 turbo 350
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Triple Blue 10 D 68
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1968 Chevelle 03 A 68
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
8ballracing is offline  
post #8 of 14 (permalink) Old Dec 31st, 15, 11:54 PM
Senior Tech
Doug
 
Join Date: Apr 2008
Location: Hopewell, Virginia
Posts: 1,424
Re: 68 camaro blinker lights are mixed up

Check the wiring to the signal lights in the front. On my 67 my signal housing has three wires with black being the ground. Check all the sockets in the back making sure the insides are not rusted. Go thru the side marker harness too checking bulbs.
Cdminter55 is offline  
post #9 of 14 (permalink) Old Jan 2nd, 16, 04:37 PM Thread Starter
angelo
 
Join Date: Dec 2015
Location: Richmond texas
Posts: 5
Re: 68 camaro blinker lights are mixed up

When signal left lights and signals work fine but when turn right nothing happens when lights r on and back left tail light blinks w rights when head lights off
yoyomo is offline  
post #10 of 14 (permalink) Old Jan 2nd, 16, 04:38 PM Thread Starter
angelo
 
Join Date: Dec 2015
Location: Richmond texas
Posts: 5
Re: 68 camaro blinker lights are mixed up

Fuses look fine and cleaned out housing where bulbs go in. What next? Thanks
yoyomo is offline  
post #11 of 14 (permalink) Old Jan 2nd, 16, 10:32 PM
Gold Lifetime Member
Jeff
 
yellow69RS's Avatar
 
Join Date: Jul 2007
Location: Aurora, IL
Posts: 5,134
Send a message via Yahoo to yellow69RS
Re: 68 camaro blinker lights are mixed up

Quote:
Originally Posted by yoyomo View Post
My 68 camaro blinker lights are mixed up. When I turn indicator to right they all blink as if hazards are on unless my lights r on then nothing happens. When I turn indicator to the left they work fine with or without light on. And hazards don't work at all. What do I need to do? Thanks
Is the hazard switch in the on position?
What does it do when you step on the brakes?

The Hazard flasher is in a different spot from the T/S flasher be sure it's there and good.

I'll assume you've checked to be sure no light bulbs have a single "wart" on the bottom. The correct ones for T/S-running lights should have two.

Jeff
yellow69RS is offline  
post #12 of 14 (permalink) Old Jan 3rd, 16, 06:26 AM
Senior Tech
mike
 
Join Date: Jan 2011
Location: east coast
Posts: 2,288
Re: 68 camaro blinker lights are mixed up

Did you try taking one bulb out a a time and leaving it out while attempting test? I have had bulbs that were crossed wired in the bulb.
bigblockragtop is offline  
post #13 of 14 (permalink) Old Jan 3rd, 16, 07:14 AM
Retired
Jim
 
click's Avatar
 
Join Date: Jun 2001
Location: Central Minnesota
Posts: 15,985
Re: 68 camaro blinker lights are mixed up

Go back over ALL your grounds. Behind instrument cluster, guages to ground, headlight switch to body, even dimmer switch on the floor board needs good ground as do the Battery to frame, frame to body straps, regulator on the radiator support, etc. Everywhere you can find a wire going to a fender, frame etc, pull it apart, clean it up, clean the mating surface too (wire brush) then use star washers to ensure a good ground. you will find it, but elec. gremlins are the worst but usually the easiest to fix once you find the bad one. Its like that lost jig saw puzzle piece under the sofa... you know its there.

Click..is Jim..former owner of a 69RS-LM1 350/255 - 700r
"There will come a time when you believe everything is finished,
That will be the beginning." Louis L'Amour
click is offline  
post #14 of 14 (permalink) Old Jan 3rd, 16, 11:02 AM
Senior Tech
George
 
Join Date: Aug 2014
Location: LI,NY
Posts: 1,057
Re: 68 camaro blinker lights are mixed up

Quote:
Originally Posted by yoyomo View Post
My 68 camaro blinker lights are mixed up. When I turn indicator to right they all blink as if hazards are on unless my lights r on then nothing happens. When I turn indicator to the left they work fine with or without light on. And hazards don't work at all. What do I need to do? Thanks
Did you get the car this way? Was it ever working right? Did you make some modification and now its like this? What is the back story to this problem.
carbuff67rs is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome