69 Z28 Right Turn Signal not flashing - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jan 18th, 16, 06:05 PM Thread Starter
Rick
 
Join Date: Jan 2016
Location: Atlanta
Posts: 1
69 Z28 Right Turn Signal not flashing

right rear comes on but no flash. right front was working intermittently but now not at all. Tried new bulb in front but does not work -- does not light up at all and, of course, no flash. What is the order of items I should check to resolve fastest. Car has been restored several years ago and wires appear to be in great shape. Just bought the car last month. Thanks.
rickgilbert is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jan 18th, 16, 06:26 PM
Gold Lifetime Member
Scott
 
scblucam's Avatar
 
Join Date: May 2005
Location: Houston, TX
Posts: 2,484
Garage
Re: 69 Z28 Right Turn Signal not flashing

Almost always ground

68 302 M20 - 85 IROC Z
The older I get the faster I was.
scblucam is offline  
post #3 of 5 (permalink) Old Jan 19th, 16, 03:05 AM
ds1
Senior Tech
Dan
 
Join Date: Feb 2014
Location: Lewistown. PA
Posts: 215
Garage
Re: 69 Z28 Right Turn Signal not flashing

Yes sounds like a poor ground
ds1 is offline  
 
post #4 of 5 (permalink) Old Jan 19th, 16, 04:08 AM
Senior Tech
Steve
 
Join Date: Jun 2005
Location: central New York
Posts: 1,646
Re: 69 Z28 Right Turn Signal not flashing

Check for corrosion in the socket, common problem.

1969 Z28

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Firebird 400

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My new project for 2010 DONE/ Sold.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2002 Camaro SS LE/SLP
67 Nova SS 327, M20, 3.73
nashcar is offline  
post #5 of 5 (permalink) Old Jan 19th, 16, 08:21 AM
Gold Lifetime Member
Jeff
 
yellow69RS's Avatar
 
Join Date: Jul 2007
Location: Aurora, IL
Posts: 5,143
Send a message via Yahoo to yellow69RS
Re: 69 Z28 Right Turn Signal not flashing

Quote:
Originally Posted by scblucam View Post
Almost always ground
At the front parking lamp housing to the lower Valance.

Jeff
yellow69RS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome