67 Camaro Dash Turn Signals - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Apr 29th, 16, 08:18 PM Thread Starter
Vinny
 
Join Date: Oct 2015
Location: Shingle Springs, CA
Posts: 2
67 Camaro Dash Turn Signals

I just put in a new tach and put the dash together for the third time. Here's the issue, the signals work on the outside of the car, but are not working in the dash (those green arrows). The Tach, and Brake light works. Please help...

Vinny
VinnyCamaro is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Apr 29th, 16, 08:37 PM
 
Join Date: Apr 2016
Posts: 24
Re: 67 Camaro Dash Turn Signals

Maybe a blown fuse or something?
peter123wallace is offline  
post #3 of 4 (permalink) Old Apr 29th, 16, 08:43 PM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,511
Garage
Re: 67 Camaro Dash Turn Signals

Check two things.
First the ground of the cluster which is achieved by the "paper-clip" at the screw by the high-bream indicator.
Second make sure the ribbon connector is right and tight on the printed circuit board.

Ground issues are the most common issue for weird cluster functions. You can and maybe should like so many others with 67, and 68's add a real ground wire from the cluster using one of the screws on the back lower left and then connect the ground to knows good point behind the dash. Check the sticky in the electrical section how to fix your dash lights. https://www.camaros.net/forums/19-ele...step-step.html


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
 
post #4 of 4 (permalink) Old May 2nd, 16, 03:16 AM
Senior Tech
Kevin
 
Join Date: Mar 2016
Location: Lake Mary, Florida
Posts: 422
Re: 67 Camaro Dash Turn Signals

And not to overlook the obvious, check the bulbs themselves. Anytime I have a cluster out for diagnosing an issue, I put in brand new bulbs if they are a year or more old.

Never argue with an idiot; they'll only drag you down to their level, then beat you with experience.
bucko is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome