67 RS - Many problems - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jun 26th, 03, 03:50 PM Thread Starter
 
Join Date: Jun 2003
Location: Augusta GA
Posts: 1
Post

I have a 67 RS with guage package. New wiring harness, vintage air, electric cooling fan. Alpine Radio.

When driving, the air conditioner fluctuates on and off - slower and faster. It seems at higher RPMs, it blows normal. Sometimes I have a total power loss where the engine keeps running but the fan, radio, guages, AC, etc, all fail.

The TEMP guage fluctuates wildly sometimes. Sometimes when the key switch is on but not cranked, the AC will blow lightly even with the switch off


PLEASE HELP
Jim Drew is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jun 27th, 03, 04:00 AM
Senior Tech
 
Join Date: Sep 2001
Location: Temple City, Ca
Posts: 523
Post

Where I would start? It almost sounds like you have the engine ground but may be loosing it to everything else. Think the first thing I would check is the battery (-) to the right inside fender ground wire. See that everything is in good shape, clean, and tight.
Next thing I would look at is the output from the alternator. See what the readings are at idle and maybe 2000 rpm. Look for around 14 volts. Maybe it’s not handling the electric fan and A/C.
John_Muha is offline  
post #3 of 4 (permalink) Old Jun 29th, 03, 01:56 PM
Tech Team
 
Join Date: Dec 2002
Location: Phoenix AZ.
Posts: 72
Post

Possibly you need a ground strap from the engine to the firewall. HJade similar problem few years ago used metal ground strap. Worth a try couple of bucks.

67 Camaro
bobmeyer58 is offline  
 
post #4 of 4 (permalink) Old Jun 30th, 03, 05:02 AM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,480
Garage
Post

What have you done to your charging system to handle the added load. The fact that at higher rpm things work better indicates the draw is too great on the system at lower rpm when the alt is turning slower.

Ground straps from frame to firewall or valve cover to firewall are part of a radio option for noise suppression. Bob - the straps helped you so I bet you had a poor ground elsewhere in your system...

...Dennis

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Don't take life so serious, you won't get out alive..."
DjD is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome